summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gmtk
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gmtk')
-rw-r--r--media-libs/gmtk/Manifest2
-rw-r--r--media-libs/gmtk/gmtk-1.0.8.ebuild48
-rw-r--r--media-libs/gmtk/gmtk-1.0.9.ebuild48
-rw-r--r--media-libs/gmtk/metadata.xml11
4 files changed, 109 insertions, 0 deletions
diff --git a/media-libs/gmtk/Manifest b/media-libs/gmtk/Manifest
new file mode 100644
index 000000000000..9d09addb744d
--- /dev/null
+++ b/media-libs/gmtk/Manifest
@@ -0,0 +1,2 @@
+DIST gmtk-1.0.8.tar.gz 407790 SHA256 007fba85f4ba6af6b3fd9d5162e18a7e4059c848e112eb03b84b2c7aad008b0c SHA512 ef2bff079df5ba41b86b52118b51bfe0343093e206dd7eca0da39f0420eca4d2f3cbb93940ecadb1526303c8ca0f9b27ff61cbd193122cc91a0fff768e6601ee WHIRLPOOL cc64ee0b4a6df03aeddd914bb3018274a0de9fe1930ff54e8e65352bbcbd1ed3d460eed1dde0a054fd7c7edd7bc9cb52eab0d2c361637dc437655dc01c794130
+DIST gmtk-1.0.9.tar.gz 411609 SHA256 d633832ab3b223f9a669934d168c74574ab47a6a21f76d942c05ad78c56bf87a SHA512 61da4bbba5b74510c5ad5d6b5e10606fb99f54732cf412aa6245add2dc2b0df12b75e4e6f1474b4cab0541063ba6f95893e366f1c8b52a055521b667c182dcdf WHIRLPOOL a9fcfd67880f5caf50560a8a71f677b7d9a9cf49b5e9ec8f4572f41b2bc448e27c5a6d8143cbc6fe9a10fc86671094e10ac52ce9abe41190d60ded1c32350459
diff --git a/media-libs/gmtk/gmtk-1.0.8.ebuild b/media-libs/gmtk/gmtk-1.0.8.ebuild
new file mode 100644
index 000000000000..22132e3af2d5
--- /dev/null
+++ b/media-libs/gmtk/gmtk-1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="GTK+ widget and function libraries for gnome-mplayer"
+HOMEPAGE="http://code.google.com/p/gmtk/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86"
+IUSE="alsa +dconf pulseaudio"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${COMMON_DEPEND}
+ dconf? ( gnome-base/dconf )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-gtk3 \
+ $(use_enable dconf gsettings) \
+ --disable-gconf \
+ $(use_enable !dconf keystore) \
+ --with-gio \
+ $(use_with alsa) \
+ $(use_with pulseaudio)
+}
+
+src_install() {
+ default
+
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files
+}
diff --git a/media-libs/gmtk/gmtk-1.0.9.ebuild b/media-libs/gmtk/gmtk-1.0.9.ebuild
new file mode 100644
index 000000000000..a3bed22b12c6
--- /dev/null
+++ b/media-libs/gmtk/gmtk-1.0.9.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="GTK+ widget and function libraries for gnome-mplayer"
+HOMEPAGE="http://code.google.com/p/gmtk/"
+SRC_URI="http://${PN}.googlecode.com/svn/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 x86"
+IUSE="alsa +dconf pulseaudio"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+RDEPEND="${COMMON_DEPEND}
+ dconf? ( gnome-base/dconf )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --enable-gtk3 \
+ $(use_enable dconf gsettings) \
+ --disable-gconf \
+ $(use_enable !dconf keystore) \
+ --with-gio \
+ $(use_with alsa) \
+ $(use_with pulseaudio)
+}
+
+src_install() {
+ default
+
+ rm -rf "${ED}"/usr/share/doc/${PN}
+ prune_libtool_files
+}
diff --git a/media-libs/gmtk/metadata.xml b/media-libs/gmtk/metadata.xml
new file mode 100644
index 000000000000..5e8e19936618
--- /dev/null
+++ b/media-libs/gmtk/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name='dconf'>Enable support for <pkg>gnome-base/dconf</pkg></flag>
+ </use>
+</pkgmetadata>