summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-10-30 17:07:27 -0300
committerPacho Ramos <pacho@gentoo.org>2024-11-08 19:16:06 +0100
commit7848a164f5dc4b6e8822581c7109e49fd907378d (patch)
tree5a26f9f9ddf472d133c46aa3d05122231c3087d9 /media-gfx
parentmedia-fonts/noto: drop 20240630 (diff)
downloadgentoo-7848a164f5dc4b6e8822581c7109e49fd907378d.tar.gz
gentoo-7848a164f5dc4b6e8822581c7109e49fd907378d.tar.bz2
gentoo-7848a164f5dc4b6e8822581c7109e49fd907378d.zip
media-gfx/shotwell: Bump to 0.32.10
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39162 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/shotwell/Manifest1
-rw-r--r--media-gfx/shotwell/shotwell-0.32.10.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 327114fa4557..222a967b2e1d 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,3 +1,4 @@
+DIST shotwell-0.32.10.tar.xz 35339616 BLAKE2B b68c755605df75ce5edd82d042690fc09236996e030973331a2fc8ecbf078e6c2ffd48d46bfd0a74783cd7fc7ced035a7ba685c2fdf488394ead850b717a2ff5 SHA512 adb670417a698d53f5fd865b70cd394be2779d9ada4a1bbcc3c1af67cd7e39ca79a303beec447156bd902dc415ceaa14205544505489abc0027464ab01029304
DIST shotwell-0.32.4.tar.xz 35335296 BLAKE2B 32be135643f165f32f315c332a4f0b34cd724285e7239eadbb250253b27ce97fb15d314f68a5392d88224a0b97f7f6ef8789c1f6c40051c26a25b9012e860b90 SHA512 516ab26d6620429175097886a1874d2eaf0513f6ef732bef5ee07ef8cd200028b34d98f4eb09b47a621f5313de42a5f415185d76853de478e0b5e0c4e89eea69
DIST shotwell-0.32.7.tar.xz 35339216 BLAKE2B db87ee9c161f57dad638b47c37fb2737c95645e987e2bab81697895d9a28f14ab22b4669f218ea0baadfc0e1115f45fb9b094f546299083d83d2486fa1c15f98 SHA512 3cb9c9f2981ead8410f42680f6b4976d3b2efcfe7ded4d5217d28ebb8e5c968062a004ad3353affa13e94d996208ebf26c01f4beaf03a2ef6a1bc43960488d14
DIST shotwell-0.32.9.tar.xz 35341312 BLAKE2B 81229b088c18b73e7039d8c1e644d0280988d888af798a8f8560a83ef24138772561609cbf9d502b07dfc1bb7f0acafe1b829af7a6213bbca623dd67f0893229 SHA512 9fc4027271c0d31660aa0579a3369ad25d87454efa5fb95a17a85e962232e0e35f28ab9e2fa63aef5aa9b89d895c7a97d3edffdd862bbaa5af29d1325a19a2d0
diff --git a/media-gfx/shotwell/shotwell-0.32.10.ebuild b/media-gfx/shotwell/shotwell-0.32.10.ebuild
new file mode 100644
index 000000000000..1cbc27d4c8ad
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.32.10.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson optfeature vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8=
+ >=net-libs/webkit-gtk-2.26:4.1
+ net-libs/libsoup:3.0
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.12.3
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16
+ app-crypt/libsecret
+ >=dev-libs/libportal-0.5:=[gtk,vala]
+ media-libs/libwebp:=
+
+ >=app-crypt/gcr-3:0=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-4.0.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:3.0[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr:0[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity_support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ #trace
+ #measure
+ -Ddupe_detection=true
+ $(meson_use udev)
+ -Dinstall_apport_hook=false
+ $(meson_use opencv face_detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Enable support for the AVIF format" media-libs/libavif[gdk-pixbuf]
+ optfeature "Enable support for the HEIF format" media-libs/libheif[gdk-pixbuf]
+ optfeature "Enable support for the JPEG format" x11-libs/gdk-pixbuf[jpeg]
+ optfeature "Enable support for the TIFF format" x11-libs/gdk-pixbuf[tiff]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}