summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-09-30 16:38:11 +0000
committerSam James <sam@gentoo.org>2023-10-01 09:39:39 +0100
commit2dad7c8ef9771e02fe25e86c648da23eda3a6ac3 (patch)
treec4fc94c66d34b869b2b26c9a7e32a8609f27eb6a /media-gfx
parentnet-analyzer/tptest: Fix call to undeclared function open (diff)
downloadgentoo-2dad7c8ef9771e02fe25e86c648da23eda3a6ac3.tar.gz
gentoo-2dad7c8ef9771e02fe25e86c648da23eda3a6ac3.tar.bz2
gentoo-2dad7c8ef9771e02fe25e86c648da23eda3a6ac3.zip
media-gfx/gphotofs: Fix call to undeclared function setlocale
And update EAPI 7 -> 8 Closes: https://bugs.gentoo.org/896214 Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33139 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/gphotofs/files/gphotofs-0.5-fix-build-clang16.patch11
-rw-r--r--media-gfx/gphotofs/gphotofs-0.5-r2.ebuild25
2 files changed, 36 insertions, 0 deletions
diff --git a/media-gfx/gphotofs/files/gphotofs-0.5-fix-build-clang16.patch b/media-gfx/gphotofs/files/gphotofs-0.5-fix-build-clang16.patch
new file mode 100644
index 000000000000..0a88035cc60f
--- /dev/null
+++ b/media-gfx/gphotofs/files/gphotofs-0.5-fix-build-clang16.patch
@@ -0,0 +1,11 @@
+Bug: https://bugs.gentoo.org/896214
+--- a/gphotofs.c
++++ b/gphotofs.c
+@@ -26,6 +26,7 @@
+ #include <errno.h>
+ #include <fcntl.h>
+ #include <sys/time.h>
++#include <locale.h>
+
+ /*
+ * Static variables set by command line arguments.
diff --git a/media-gfx/gphotofs/gphotofs-0.5-r2.ebuild b/media-gfx/gphotofs/gphotofs-0.5-r2.ebuild
new file mode 100644
index 000000000000..5fe6dbff0ba6
--- /dev/null
+++ b/media-gfx/gphotofs/gphotofs-0.5-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="FUSE file system for interfacing with digital cameras using gphoto2"
+HOMEPAGE="http://www.gphoto.org/"
+SRC_URI="mirror://sourceforge/gphoto/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libgphoto2:=
+ sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5-fix-build-clang16.patch
+)