summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/wally/wally-2.4.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/wally/wally-2.4.5.ebuild')
-rw-r--r--media-gfx/wally/wally-2.4.5.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-gfx/wally/wally-2.4.5.ebuild b/media-gfx/wally/wally-2.4.5.ebuild
new file mode 100644
index 000000000000..19b48f7bf5af
--- /dev/null
+++ b/media-gfx/wally/wally-2.4.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+KDE_REQUIRED="optional"
+
+inherit eutils kde4-base readme.gentoo
+
+DESCRIPTION="A Qt4/KDE4 wallpaper changer"
+HOMEPAGE="http://www.becrux.com/index.php?page=projects&name=wally"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="amd64 x86"
+IUSE="debug kde"
+
+DEPEND="
+ media-libs/libexif
+ x11-libs/libX11
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ kde? ( $(add_kdebase_dep kdelibs) )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ "AUTHORS" "ChangeLog" "README" "README.XFCE4"
+ "README.shortcuts" "TODO"
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.0-disable_popup.patch
+)
+
+src_prepare() {
+ DOC_CONTENTS="In order to use wallyplugin you need to
+ restart plasma in your KDE4 enviroment."
+ kde4-base_src_prepare
+ use kde || epatch "${FILESDIR}"/${PN}-2.2.0-disable-kde4.patch
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DSTATIC=FALSE
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newicon "${S}"/res/images/idle.png wally.png
+ make_desktop_entry wally Wally wally "Graphics;Qt"
+ use kde && readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ use kde && readme.gentoo_print_elog
+}