summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl@gmail.com>2018-12-23 22:30:49 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-24 22:14:38 +0200
commitb97a3ee38729699006c7a6c6e7f3bb229b84f794 (patch)
tree1843116d0ffc5c8fa6932a1e1215b6a221913d02 /media-gfx/openscad
parentmedia-gfx/openscad: add missing dependencies (diff)
downloadgentoo-b97a3ee38729699006c7a6c6e7f3bb229b84f794.tar.gz
gentoo-b97a3ee38729699006c7a6c6e7f3bb229b84f794.tar.bz2
gentoo-b97a3ee38729699006c7a6c6e7f3bb229b84f794.zip
media-gfx/openscad: bump to EAPI 7
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Bernd Waibel <waebbl@gmail.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-gfx/openscad')
-rw-r--r--media-gfx/openscad/openscad-2015.03_p3-r1.ebuild (renamed from media-gfx/openscad/openscad-2015.03_p3.ebuild)21
-rw-r--r--media-gfx/openscad/openscad-9999.ebuild16
2 files changed, 10 insertions, 27 deletions
diff --git a/media-gfx/openscad/openscad-2015.03_p3.ebuild b/media-gfx/openscad/openscad-2015.03_p3-r1.ebuild
index aee0a681df2e..1b34fa207c5e 100644
--- a/media-gfx/openscad/openscad-2015.03_p3.ebuild
+++ b/media-gfx/openscad/openscad-2015.03_p3-r1.ebuild
@@ -1,11 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit elisp-common qmake-utils xdg-utils
+inherit elisp-common qmake-utils xdg
-MY_PV="2015.03-3"
+# 2015.03-3
+MY_VER=$(ver_cut 1-2) # version component
+MY_REL=$(ver_cut 4) # release component, 'p' being the third component
+MY_PV=${MY_VER}-${MY_REL}
SITEFILE="50${PN}-gentoo.el"
DESCRIPTION="The Programmers Solid 3D CAD Modeller"
@@ -72,13 +75,3 @@ src_install() {
einstalldocs
}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
diff --git a/media-gfx/openscad/openscad-9999.ebuild b/media-gfx/openscad/openscad-9999.ebuild
index c6641079520f..e885fba11965 100644
--- a/media-gfx/openscad/openscad-9999.ebuild
+++ b/media-gfx/openscad/openscad-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit elisp-common git-r3 qmake-utils xdg-utils
+inherit elisp-common git-r3 qmake-utils xdg
SITEFILE="50${PN}-gentoo.el"
@@ -71,13 +71,3 @@ src_install() {
einstalldocs
}
-
-pkg_postinst() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_mimeinfo_database_update
- xdg_desktop_database_update
-}