summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-gfx/cellwriter
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-gfx/cellwriter')
-rw-r--r--media-gfx/cellwriter/Manifest2
-rw-r--r--media-gfx/cellwriter/cellwriter-1.3.4.ebuild30
-rw-r--r--media-gfx/cellwriter/cellwriter-1.3.5.ebuild32
-rw-r--r--media-gfx/cellwriter/metadata.xml6
4 files changed, 70 insertions, 0 deletions
diff --git a/media-gfx/cellwriter/Manifest b/media-gfx/cellwriter/Manifest
new file mode 100644
index 000000000000..67fb925e3563
--- /dev/null
+++ b/media-gfx/cellwriter/Manifest
@@ -0,0 +1,2 @@
+DIST cellwriter-1.3.4.tar.gz 284647 SHA256 6ab6fa697938af0fc8b587ccd7c5889087800569e558b97797963c6ee2fada0c
+DIST cellwriter-1.3.5.tar.gz 293241 SHA256 c7ea0dd4b512c80235569c033cefda7c471f335deeb472220e27c31e511e06ef SHA512 a9b682babda4335ea18716032ac52e73578459e9ab8866b20177f6d0cb606b9da2bf5a3fae2e2547277351db2533c7e92461f5c6a6ebc542ffe5844ff7ae65d6 WHIRLPOOL 6db9f3c3e9cfec653d0f69d2a8e70153372d529db53b772b9560cfeb57100d7c420dd2f605957c780b0b19dc53300e084a14f9db434a3d89ee424fed7245f0a1
diff --git a/media-gfx/cellwriter/cellwriter-1.3.4.ebuild b/media-gfx/cellwriter/cellwriter-1.3.4.ebuild
new file mode 100644
index 000000000000..a5033880d3b6
--- /dev/null
+++ b/media-gfx/cellwriter/cellwriter-1.3.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="Grid-entry natural handwriting input panel"
+HOMEPAGE="http://risujin.org/cellwriter/"
+SRC_URI="http://pub.risujin.org/cellwriter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="gnome"
+
+RDEPEND="x11-libs/libXtst
+ >=x11-libs/gtk+-2.10:2
+ gnome? ( gnome-base/libgnome )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/inputproto"
+
+src_configure() {
+ econf $(use_with gnome)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/media-gfx/cellwriter/cellwriter-1.3.5.ebuild b/media-gfx/cellwriter/cellwriter-1.3.5.ebuild
new file mode 100644
index 000000000000..412016de9ef3
--- /dev/null
+++ b/media-gfx/cellwriter/cellwriter-1.3.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit gnome2-utils
+
+DESCRIPTION="Grid-entry natural handwriting input panel"
+HOMEPAGE="http://risujin.org/cellwriter/"
+SRC_URI="http://pub.risujin.org/cellwriter/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog README TODO" # NEWS is no-op
+
+src_prepare() {
+ sed -i -e '/Encoding/d' ${PN}.desktop || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }
diff --git a/media-gfx/cellwriter/metadata.xml b/media-gfx/cellwriter/metadata.xml
new file mode 100644
index 000000000000..530e784188f3
--- /dev/null
+++ b/media-gfx/cellwriter/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>graphics</herd>
+</pkgmetadata>
+