summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-03-20 16:48:54 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-06 13:48:05 -0400
commit8414150b4e313d3aa68f01528ce2662b33f4ba29 (patch)
treeaa4e646d189446f581b03686923bd2cc2f40c448 /mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild
parentmate-base/caja: Fix LICENSE (diff)
downloadgentoo-8414150b4e313d3aa68f01528ce2662b33f4ba29.tar.gz
gentoo-8414150b4e313d3aa68f01528ce2662b33f4ba29.tar.bz2
gentoo-8414150b4e313d3aa68f01528ce2662b33f4ba29.zip
mate-extra/mate-polkit: Bump to 1.24.0
Package-Manager: Portage-2.3.82, Repoman-2.3.18 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild')
-rw-r--r--mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild b/mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild
new file mode 100644
index 000000000000..5b5b4f8de066
--- /dev/null
+++ b/mate-extra/mate-polkit/mate-polkit-1.24.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="A MATE specific DBUS service that is used to bring up authentication dialogs"
+LICENSE="LGPL-2"
+SLOT="0"
+
+IUSE="accountsservice appindicator"
+
+COMMON_DEPEND=">=dev-libs/glib-2.50:2
+ >=sys-auth/polkit-0.102
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22.0:3
+ appindicator? ( dev-libs/libappindicator:3 )"
+
+RDEPEND="${COMMON_DEPEND}
+ accountsservice? ( sys-apps/accountsservice )
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/libtool-2.2.6
+ virtual/pkgconfig:*
+ !<gnome-extra/polkit-gnome-0.102:0"
+
+src_configure() {
+ mate_src_configure \
+ --disable-static \
+ $(use_enable accountsservice) \
+ $(use_enable appindicator)
+}