summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-04-10 14:45:51 +0100
committerMarek Szuba <marecki@gentoo.org>2023-04-10 14:46:11 +0100
commit3ff0c3a25008b104035e31dbaa39f06ccfaf2bd7 (patch)
tree2debe933011fa942161dcbe6893a4bd53641490f /mail-mta
parentgames-action/minetest: disable upstream update checker for new configs (diff)
downloadgentoo-3ff0c3a25008b104035e31dbaa39f06ccfaf2bd7.tar.gz
gentoo-3ff0c3a25008b104035e31dbaa39f06ccfaf2bd7.tar.bz2
gentoo-3ff0c3a25008b104035e31dbaa39f06ccfaf2bd7.zip
mail-mta/proton-mail-bridge: add 3.0.21
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'mail-mta')
-rw-r--r--mail-mta/proton-mail-bridge/Manifest2
-rw-r--r--mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/mail-mta/proton-mail-bridge/Manifest b/mail-mta/proton-mail-bridge/Manifest
index dbdfa8254ea8..02d0b96025d3 100644
--- a/mail-mta/proton-mail-bridge/Manifest
+++ b/mail-mta/proton-mail-bridge/Manifest
@@ -1,2 +1,4 @@
DIST proton-mail-bridge-2.3.0-deps.tar.xz 237367120 BLAKE2B 819ffc216017db8a02a189fdb1b4c78e26d38f1cde94bbc556e8603047e396ce0de3caa2b3cf18392a30fbaab525c305f6f0193fb1210baeb48f6a346ae2ba94 SHA512 63076459bf1e8c17775439a5ef1e22482684e0f37a45a4b6f9469c851e66b984f1bce5c19c1d4bfa8cbf5f9ae4fe21a5a20d8304254cdc4f215120dfe5b254e7
DIST proton-mail-bridge-2.3.0.tar.gz 5059969 BLAKE2B 3871ec75e69ce2976a3b588c9cb32dc61d5c6eaf28a8a7941fb91babbe74cf73f101a3fa9d87c999c659847a42b0a3d93298d6c692a06cfe2716a31fcbb0d469 SHA512 3e3a64d945577a4efc1cb1e9a3b029465f64fab37e80fa7d58e7ea94ba316281596e91a6b49fc37168a0275921f3f79567f58eb926a1d77fcc0b8b39a3cf8f5c
+DIST proton-mail-bridge-3.0.21-deps.tar.xz 169294240 BLAKE2B ee463d96d01e702180f86765a36bc59c72454f13caed22183e68a6875c1dad4b7614966dabdd43915b2762d3de69b8fb3cac1011a48bf50d8f3cc1dbf3a96420 SHA512 6bce4cfcdf1704a6599f925ff59fd367c6750f92f75bee886f656f609a5368eb75f865f642ae63e87bafe3609e7620b0c27dfbec40e281cc8a92221af24f9661
+DIST proton-mail-bridge-3.0.21.tar.gz 4416496 BLAKE2B 6199338b6265c8d3e7108cd7b149fa4e32e56e3ecb7f299e66f4d072d78d8b21a919e52c510c509613958adbacf32d8a4dccb2891a77efa4dec83d483e560266 SHA512 30adc2e4947309fb274a5f86ff450a41685d30b27854b9a00f033adc65d33bcbff19ee830c50ae5bea0c2ac178bc5a4960912486edd4954f928ff075b7441d82
diff --git a/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21.ebuild b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21.ebuild
new file mode 100644
index 000000000000..a9020b672022
--- /dev/null
+++ b/mail-mta/proton-mail-bridge/proton-mail-bridge-3.0.21.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd xdg-utils
+
+MY_PN="${PN/-mail/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Serves ProtonMail to IMAP/SMTP clients"
+HOMEPAGE="https://proton.me/mail/bridge https://github.com/ProtonMail/proton-bridge/"
+SRC_URI="https://github.com/ProtonMail/${MY_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~marecki/dists/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-3+ ISC LGPL-3+ MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="gui"
+
+# Quite a few tests require Internet access
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="app-crypt/libsecret"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ xdg_environment_reset
+ default
+}
+
+src_compile() {
+ if use gui; then
+ eerror "Since version 3.0.0, GUI support in ${PN} requires Qt6 and is therefore currently not available"
+ die "USE=gui requires Qt6"
+ else
+ emake build-nogui
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ exeinto /usr/bin
+ newexe bridge ${PN}
+
+ systemd_douserunit "${FILESDIR}"/${PN}.service
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ use gui && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gui && xdg_icon_cache_update
+}