summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHolger Hoffstätte <holger@applied-asynchrony.com>2024-11-21 12:31:38 +0100
committerSam James <sam@gentoo.org>2024-11-25 21:52:23 +0000
commitcdb3cc704d92ce3af5ee49e809702aa1be18f737 (patch)
treeba940a6b75fbd93441fa0f455cf09ebe5ef0b6b5 /mail-client
parentmail-client/alpine: add myself as proxy-maintainer (diff)
downloadgentoo-cdb3cc704d92ce3af5ee49e809702aa1be18f737.tar.gz
gentoo-cdb3cc704d92ce3af5ee49e809702aa1be18f737.tar.bz2
gentoo-cdb3cc704d92ce3af5ee49e809702aa1be18f737.zip
mail-client/alpine: add upstream patches to fix build with gcc-15
Add patches from upstream git to fix all serious C99/C23 problems. The "chappa" extension patches were rebased on top of that. This should tide us over until the next release. Closes: https://bugs.gentoo.org/944148 Signed-off-by: Holger Hoffstätte <holger@applied-asynchrony.com> Closes: https://github.com/gentoo/gentoo/pull/39395 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/alpine/Manifest1
-rw-r--r--mail-client/alpine/alpine-2.26-r5.ebuild109
2 files changed, 110 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index 2173f8e5f4c2..d5563af43e6d 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,2 +1,3 @@
DIST alpine-2.26-chappa-5.patch.gz 173031 BLAKE2B 8719d37fde313e190608489e6191d4f0456f8a00ea267712e1c078ab1bbd3a8542bab3cf498faa1482fde386c24bf5335c54c39595ffb7fb019d13e975bf697a SHA512 aa979825367b309d5726055620c6f8f3effff954863e648de25f768ffbc175c3f91c8d1917e89116f35195a5ae266a9dcac51eb7f744f119ad848ddc0d10b8cc
+DIST alpine-2.26-patches-1.tar.xz 492948 BLAKE2B 00f7b0ac6f138522a0cdeefcdad084f8662f781dc6f415223646a5915e189c120fd7bcdb0c4ff455eb6db379faf18dfebd4dbb539833e295b2cb08719119128b SHA512 4fbf94fbad58a5d531c9637e3ad5c7288e055c151fe99300d760dbcf93497d7c3ac000df280f3d3e5f5302a0f08c7c7be4eb4f0a95fb08f736a9863aaf3d4fd6
DIST alpine-2.26.tar.xz 7517628 BLAKE2B fe156974462dd566ac3fbe25cc54a1b2a480b3af46c8356356a97426f3e42495853efdbfeedc6173537dc150d90592c3fd9109e7d37f16738922a4205fd2f9df SHA512 359b5cb30be78a341b76c0475a2d5268b643788f14c9b5b9457af6748034e1d2e70fd7ddf59e5c59ad596a36d8a10afa9c41cbd74241c780b8575d8186168fd2
diff --git a/mail-client/alpine/alpine-2.26-r5.ebuild b/mail-client/alpine/alpine-2.26-r5.ebuild
new file mode 100644
index 000000000000..60568914b89e
--- /dev/null
+++ b/mail-client/alpine/alpine-2.26-r5.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic optfeature toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="https://alpineapp.email/ https://repo.or.cz/alpine.git/"
+SRC_URI="https://alpineapp.email/alpine/release/src/${P}.tar.xz
+ https://www.applied-asynchrony.com/distfiles/${P}-patches-1.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+chappa ipv6 kerberos ldap nls onlyalpine passfile smime ssl"
+
+DEPEND="sys-libs/ncurses:=
+ virtual/libcrypt:=
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap:= )
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+
+ # apply patches from upstream git to fix compiler issues
+ local patches=$(find "${WORKDIR}/${P}-patches" -type f -name "0*.patch")
+ for patch in ${patches}; do
+ eapply "${patch}"
+ done
+
+ # optional extra features, see https://alpineapp.email/alpine/index.html
+ use chappa && eapply "${WORKDIR}/${P}-patches/chappa-rebased.patch"
+
+ eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-pthread
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if has_version "app-text/hunspell"; then
+ myconf+=( --with-interactive-spellcheck=/usr/bin/hunspell )
+ elif has_version "app-text/aspell"; then
+ myconf+=( --with-interactive-spellcheck=/usr/bin/aspell )
+ fi
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+
+ # Bug 935343; see imap/docs/bugs.txt
+ if use ipv6; then
+ sed -i "s/IP=4/IP=6/" imap/Makefile || die
+ fi
+
+ # dial down warnings about unused results
+ append-flags -Wno-unused-result
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ # the bundled c-client lib stumbles with both -j>1 and --shuffle #888709
+ emake -j1 --shuffle=none AR="$(tc-getAR)" c-client
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+ dodoc NOTICE README*
+ dodoc doc/brochure.txt
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+}
+
+pkg_postinst() {
+ optfeature "Spell checking" app-text/hunspell app-text/aspell
+}