summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-11-07 16:29:44 +0200
committerJimi Huotari <chiitoo@gentoo.org>2024-11-08 01:11:49 +0200
commitf452b810d46d09cdbbfc0c904cd82f5876d0d76c (patch)
tree2ed472a6d53cb71dc7a9e52fbc0ef3241baf51f5 /lxqt-base
parentlxqt-base/lxqt-session: add 2.1.0 (diff)
downloadgentoo-f452b810d46d09cdbbfc0c904cd82f5876d0d76c.tar.gz
gentoo-f452b810d46d09cdbbfc0c904cd82f5876d0d76c.tar.bz2
gentoo-f452b810d46d09cdbbfc0c904cd82f5876d0d76c.zip
lxqt-base/lxqt-sudo: add 2.1.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-sudo/Manifest1
-rw-r--r--lxqt-base/lxqt-sudo/lxqt-sudo-2.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-sudo/Manifest b/lxqt-base/lxqt-sudo/Manifest
index 605dc82561f3..7267c2de2a69 100644
--- a/lxqt-base/lxqt-sudo/Manifest
+++ b/lxqt-base/lxqt-sudo/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-sudo-1.4.0.tar.xz 37764 BLAKE2B d7c6d87542b84ec418d66a9e4558a66250852f1382d9ad71a1e79e7f740bfc95c043c5589fcae60cab63e7ce4ffd9e785eb3179e0cdf31c31d83431ee4962eef SHA512 0f9eda1ae4272410b18fdce1059702715c1f8ea3d75893a00d18890b713cd0269a727f95e95959a3156d998447770b666119b068c2d1af9686938fb03a59e16e
DIST lxqt-sudo-2.0.0.tar.xz 39164 BLAKE2B ab17745ced9d41fb63af7dc3646939578b79ba16a8f17739a2306114581f0c81517ad47430615fc043960638d25b062f38b4f1b1884247a8b5507723185383fc SHA512 8c79e782293f496c4e3a7d0bfbee06fb73fd682332b9bd4efa94b0ffd132e9980c64d4aa9d2719b805a7a209432595527231b9088e829b4638cc086c674f70a6
+DIST lxqt-sudo-2.1.0.tar.xz 39332 BLAKE2B 2ee1dc56804a7b7dd5a2c10e8b85e581852327f8ce195a41747d1cbd5dc66e26746f3685f0a2893eae57d659bc015027185710d4afcff71202ada0ae5c4d1996 SHA512 c700436129cd03f1df9f71de6b1c88286ada09de6d9af89f3181ef3c5dd6f9026f3f9666d0bdf2112b1b2b2fe2c559c15ff09bb812c091898c3d95b5b5e3e74c
diff --git a/lxqt-base/lxqt-sudo/lxqt-sudo-2.1.0.ebuild b/lxqt-base/lxqt-sudo/lxqt-sudo-2.1.0.ebuild
new file mode 100644
index 000000000000..c323e21dba2c
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/lxqt-sudo-2.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt GUI frontend for sudo"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.1.0"
+DEPEND="
+ app-admin/sudo
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ ~lxqt-base/liblxqt-${PV}:=
+"
+RDEPEND="${DEPEND}"