summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-11-07 16:27:44 +0200
committerJimi Huotari <chiitoo@gentoo.org>2024-11-08 01:11:49 +0200
commit950b23e71a3e3f656569c79cad2ca5dbe4138293 (patch)
treee385642a9750bd5ba04cb0160dabd6597a53c11d /lxqt-base
parentlxqt-base/lxqt-powermanagement: add 2.1.0 (diff)
downloadgentoo-950b23e71a3e3f656569c79cad2ca5dbe4138293.tar.gz
gentoo-950b23e71a3e3f656569c79cad2ca5dbe4138293.tar.bz2
gentoo-950b23e71a3e3f656569c79cad2ca5dbe4138293.zip
lxqt-base/lxqt-qtplugin: add 2.1.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'lxqt-base')
-rw-r--r--lxqt-base/lxqt-qtplugin/Manifest1
-rw-r--r--lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-qtplugin/Manifest b/lxqt-base/lxqt-qtplugin/Manifest
index 3fefa11eccad..6b27ed0cc13f 100644
--- a/lxqt-base/lxqt-qtplugin/Manifest
+++ b/lxqt-base/lxqt-qtplugin/Manifest
@@ -1,2 +1,3 @@
DIST lxqt-qtplugin-1.4.0.tar.xz 23880 BLAKE2B b9a6a5ac280bb27546a463bd1ab75db3b116d45b5327d6239a1f40cb4dac0d4605035d63fea8c4274272ef8bbeda0189449c2df2bbe45c6d2559945dc72e9549 SHA512 1d6306d396e560fbab1c64e2dda47e0456e6d8fcff077bcb7104adb8f89ef73bfef9457ab5b65aa07101acc3d7d2701efb88e8d36a0c74780a187480288acbea
DIST lxqt-qtplugin-2.0.0.tar.xz 24128 BLAKE2B 54a342dff7e7b93fa5ddbc466d408cb2e215b1c05208f76752c3651d6c2cf91708a9b62c951e9595854e2312c6cb13c2de57b364797fcadee803aaaa45c18679 SHA512 aac58511a309f162e69cbf00ae90f611e4bd8665576388d73e97e324ade2532e8ece7098ccd0c362b0674e1491f203258635f0b81738c92690b987b0f5ccf856
+DIST lxqt-qtplugin-2.1.0.tar.xz 24212 BLAKE2B b42fbebff1ae353c6218a7cead755560b7aea5db16cabbe40a08b904453382519603e87ea5fb05dc17cea8705f738914ae32993e00d507f9d50083939dc9b4dc SHA512 67572249e5c2795b8c9a3bb112d2300849765c82149331773e49eed8aa3f31bb6e4ba22c17ee17ff4bfd4b3b19dbeaf75d756912d8f9693923accb07f0a4c8d7
diff --git a/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0.ebuild b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0.ebuild
new file mode 100644
index 000000000000..b4147d9e3f65
--- /dev/null
+++ b/lxqt-base/lxqt-qtplugin/lxqt-qtplugin-2.1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake
+
+DESCRIPTION="LXQt system integration plugin for Qt"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.1.0
+"
+DEPEND="
+ dev-libs/libdbusmenu-lxqt
+ >=dev-libs/libqtxdg-4.1.0
+ >=dev-qt/qtbase-6.6:6=[dbus,gui,widgets]
+ =x11-libs/libfm-qt-${MY_PV}*
+"
+RDEPEND="${DEPEND}"