summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 13:40:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-08 14:32:55 +0100
commit5e0f583660d70d633152b9639af6b52e6f690090 (patch)
tree361e6c35245cbfb031ee399a9d3d441768480d8e /kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.5.ebuild
parentdev-lang/ruby: Added sys-libs/readline to RDEPEND. (diff)
downloadgentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.gz
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.tar.bz2
gentoo-5e0f583660d70d633152b9639af6b52e6f690090.zip
kde-plasma: Add KDE Plasma 5.14.5
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.5.ebuild')
-rw-r--r--kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.5.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.5.ebuild b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.5.ebuild
new file mode 100644
index 000000000000..b141c1e8b942
--- /dev/null
+++ b/kde-plasma/xembed-sni-proxy/xembed-sni-proxy-5.14.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+FRAMEWORKS_MINIMAL="5.50.0"
+QT_MINIMAL="5.9.6"
+KDE_AUTODEPS="false"
+KMNAME="plasma-workspace"
+inherit kde5
+
+DESCRIPTION="Legacy xembed tray icons support for SNI-only system trays"
+HOMEPAGE="https://cgit.kde.org/plasma-workspace.git/tree/xembed-sni-proxy/Readme.md"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+
+DEPEND="
+ $(add_frameworks_dep extra-cmake-modules)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_qt_dep qtcore)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/libXtst
+ x11-libs/xcb-util-image
+"
+RDEPEND="${DEPEND}
+ !<kde-plasma/plasma-workspace-5.14.2:5
+ !kde-plasma/xembed-sni-proxy:0
+"
+
+S="${S}/${PN}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.14.2-standalone.patch" )
+
+src_prepare() {
+ kde5_src_prepare
+
+ sed -e "/set/s/GENTOO_PV/${PV}/" \
+ -e "/set/s/GENTOO_QT_MINIMAL/${QT_MINIMAL}/" \
+ -e "/set/s/GENTOO_KF5_MINIMAL/${FRAMEWORKS_MINIMAL}/" \
+ -i CMakeLists.txt || die "Failed to prepare CMakeLists.txt"
+}