summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2017-01-31 15:35:17 +0100
committerJohannes Huber <johu@gentoo.org>2017-01-31 15:35:17 +0100
commite09ee8c07e6739e5133b6a67f305aebabac9dd27 (patch)
tree1570eb17cf01238060d339226650a92282201ed1 /kde-plasma/kwallet-pam
parentmedia-libs/openh264: Restrict nasm dep to x86 ABIs which are the only one nee... (diff)
downloadgentoo-e09ee8c07e6739e5133b6a67f305aebabac9dd27.tar.gz
gentoo-e09ee8c07e6739e5133b6a67f305aebabac9dd27.tar.bz2
gentoo-e09ee8c07e6739e5133b6a67f305aebabac9dd27.zip
kde-plasma: Version bump KDE Plasma 5.9.0
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.9.0.ebuild94
2 files changed, 95 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index 63c2512077b6..68161443c39a 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1 +1,2 @@
DIST kwallet-pam-5.8.5.tar.xz 17752 SHA256 84d0e3b09c353ca81af52956842fbb6170d3990293ced7f81eb4bb7447de200c SHA512 749847751872b899a4675dc7e96d4f88e47f1ceb992d84b4c99140bf2916f981fcd8c26486459f492ef810d84fb1294007c073ce238bb11bba106f9d96640f62 WHIRLPOOL 4c0ab2bca3abf5dfce7b67ee0c9e3cf2cc84e938278529aa83347ef7f77411a53490de1b0b76753d558f916860600ead985f9b28f44edc4f2f16fc74b5496951
+DIST kwallet-pam-5.9.0.tar.xz 17824 SHA256 1b7c39c06884cb75f3985935d5644a695ae9d462c22dd45ea4af101ee2c9b696 SHA512 003c1e4da62052465931451d24cc7eaa2c828413ae22069085d4bee7ea14880aefa53c8c83cce81a9956b138b139716c8c2fb56fcfbda7fb889b251ce8c14f93 WHIRLPOOL 11f6811974651fa5540c6bb90b452f7e8bf3d105fe2f55e932a0594047b3cc5a634dd7bf70915a3d2ae4589df07b40520e5510d3d3332c028b654a1110af09ab
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.9.0.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.9.0.ebuild
new file mode 100644
index 000000000000..da92a7451167
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.9.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_AUTODEPS="false"
+inherit kde5 multibuild multilib
+
+DESCRIPTION="KWallet PAM module to not enter password again"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+oldwallet"
+
+COMMON_DEPEND="
+ dev-libs/libgcrypt:0=
+ virtual/pam
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep extra-cmake-modules)
+ $(add_qt_dep qtcore)
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kwalletd-pam
+ net-misc/socat
+"
+
+pkg_setup() {
+ kde5_pkg_setup
+ MULTIBUILD_VARIANTS=( kf5 $(usev oldwallet) )
+}
+
+src_configure() {
+ myconfigure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ [[ ${MULTIBUILD_VARIANT} = oldwallet ]] && mycmakeargs+=( -DKWALLET4=1 )
+
+ kde5_src_configure
+ }
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ multibuild_foreach_variant kde5_src_compile
+}
+
+src_test() {
+ multibuild_foreach_variant kde5_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant kde5_src_install
+}
+
+pkg_postinst() {
+ check_dm() {
+ local good
+ if [[ -e "${ROOT}${2}" ]] ; then
+ if grep -Eq "auth\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" && \
+ grep -Eq "session\s+optional\s+pam_kwallet5.so" "${ROOT}${2}" ; then
+ good=true
+ fi
+ if use oldwallet ; then
+ if ! grep -Eq "auth\s+optional\s+pam_kwallet.so" "${ROOT}${2}" || \
+ ! grep -Eq "session\s+optional\s+pam_kwallet.so" "${ROOT}${2}" ; then
+ good=false
+ fi
+ fi
+ fi
+ [[ "${good}" = true ]] && \
+ elog " ${1} - ${2} ...GOOD" || \
+ ewarn " ${1} - ${2} ...BAD"
+ }
+ elog
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ use oldwallet && elog "You have also selected support for legacy kde-apps/kwalletd:4."
+ elog "List of things to make it work:"
+ elog "1. Use standard blowfish encryption instead of GPG"
+ elog "2. Use same password for login and kwallet"
+ elog "3. A display manager with support for PAM"
+ elog "4.a Have the following lines in the display manager's pam.d file:"
+ elog " -auth optional pam_kwallet5.so"
+ elog " -session optional pam_kwallet5.so auto_start"
+ if use oldwallet ; then
+ elog " -auth optional pam_kwallet.so kdehome=.kde4"
+ elog " -session optional pam_kwallet.so"
+ fi
+ elog "4.b Checking installed DMs..."
+ has_version "x11-misc/sddm" && check_dm "SDDM" "/etc/pam.d/sddm"
+ has_version "x11-misc/lightdm" && check_dm "LightDM" "/etc/pam.d/lightdm"
+ elog
+}