summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-22 23:34:29 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 00:01:02 +0100
commitdb1cfa7d6b541a396b6683c2a8df78e0cdb008e6 (patch)
tree6b80910a4f25bf9ae6f5cb7a559ebd9d2bec19f4 /kde-plasma/kwallet-pam
parentkde-plasma/plasma-desktop: drop 5.27.3 (diff)
downloadgentoo-db1cfa7d6b541a396b6683c2a8df78e0cdb008e6.tar.gz
gentoo-db1cfa7d6b541a396b6683c2a8df78e0cdb008e6.tar.bz2
gentoo-db1cfa7d6b541a396b6683c2a8df78e0cdb008e6.zip
kde-plasma/kwallet-pam: Backport 5.27.4 fixes
Fabian Vogt (3): Verify that XDG_RUNTIME_DIR is usable Don't do anything if the password is empty Exit early if the target user is root Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-plasma/kwallet-pam')
-rw-r--r--kde-plasma/kwallet-pam/Manifest1
-rw-r--r--kde-plasma/kwallet-pam/kwallet-pam-5.27.3-r1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-plasma/kwallet-pam/Manifest b/kde-plasma/kwallet-pam/Manifest
index c244de7a0b32..bc37c75831ff 100644
--- a/kde-plasma/kwallet-pam/Manifest
+++ b/kde-plasma/kwallet-pam/Manifest
@@ -1,2 +1,3 @@
DIST kwallet-pam-5.26.5.tar.xz 22808 BLAKE2B 42543b6c08dfbe873b6e2ad6503ac35b63022935ab8c40a93da432bb4d3cc240cf5da75565ef839f4cededb5c41a2a485614e47105161456f3310abcb5b79102 SHA512 bf1aeab2c4db2e0ce6e282890326b78b92ce2079f59a50d5729b0af79a7562bf845027f1f1af510181f851f7c02e4fa67c97ab58514981eca21e02ecb1ed36a3
+DIST kwallet-pam-5.27.3-patchset-1.tar.xz 1716 BLAKE2B e0a61c697399fc46a2885152e7d7c1db752ef147df21b5cfeb2e72228440e5a2aab946dc25cb5c00066c53d2e4a02bb927e6d17fdaccd988511be624f258801b SHA512 98e35c5c58491e530574b248e34126d495c8c32e7e418e5f2fed4392415e05b7cf93bfa20ec31b0796f6a9ceb58430ea16157daf8a43f348bce735530af3fa8d
DIST kwallet-pam-5.27.3.tar.xz 22844 BLAKE2B cb4fe58a5b89d4a68559328e72a82c018860a9aac806efe7dad1e673fe5b4c25e4aed0fc7f76f4586d2694cccef8300e3490237e31e5670af0e704f110105e76 SHA512 93053bd7fc8a35bed8b772b5dd4333360e7be2923ac510d96818cfc29731df3f2de378d95deb2e61d959f56d6df9477456d5a49654f64c4444e5b4800899aa51
diff --git a/kde-plasma/kwallet-pam/kwallet-pam-5.27.3-r1.ebuild b/kde-plasma/kwallet-pam/kwallet-pam-5.27.3-r1.ebuild
new file mode 100644
index 000000000000..9fa57fb8af33
--- /dev/null
+++ b/kde-plasma/kwallet-pam/kwallet-pam-5.27.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.102.0
+PVCUT=$(ver_cut 1-3)
+inherit ecm plasma.kde.org
+
+DESCRIPTION="PAM module to not enter KWallet password again after login"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/${P}-patchset-1.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="5"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libgcrypt:0=
+ >=kde-frameworks/kwallet-${KFMIN}:5
+ sys-libs/pam
+"
+RDEPEND="${DEPEND}
+ net-misc/socat
+"
+
+PATCHES=( "${WORKDIR}/${P}-patchset-1" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_LIBDIR="/$(get_libdir)"
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ elog "This package enables auto-unlocking of kde-frameworks/kwallet:5."
+ elog "See also: https://wiki.gentoo.org/wiki/KDE#KWallet_auto-unlocking"
+}