summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-04-23 12:54:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-04-23 13:02:25 +0200
commit48de0dc468f8db4db83a0fc725b667971d550c79 (patch)
tree303e857c974cc76194a2c9fe3047757f7eb0c136 /kde-misc
parentapp-emacs/gnuplot-mode: update upstream metadata (diff)
downloadgentoo-48de0dc468f8db4db83a0fc725b667971d550c79.tar.gz
gentoo-48de0dc468f8db4db83a0fc725b667971d550c79.tar.bz2
gentoo-48de0dc468f8db4db83a0fc725b667971d550c79.zip
kde-misc/kdeconnect: Add IUSE telephony
Upstream commits: 7b1f10d4d514285017928b79316ff5e061f16e86 97e47efdf6626fa0ae282684ab50ee6fce67d642 Closes: https://bugs.gentoo.org/904823 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-misc')
-rw-r--r--kde-misc/kdeconnect/files/kdeconnect-23.04.0-telephony-optional.patch40
-rw-r--r--kde-misc/kdeconnect/kdeconnect-23.04.0-r1.ebuild98
-rw-r--r--kde-misc/kdeconnect/metadata.xml1
3 files changed, 139 insertions, 0 deletions
diff --git a/kde-misc/kdeconnect/files/kdeconnect-23.04.0-telephony-optional.patch b/kde-misc/kdeconnect/files/kdeconnect-23.04.0-telephony-optional.patch
new file mode 100644
index 000000000000..bec66fd64538
--- /dev/null
+++ b/kde-misc/kdeconnect/files/kdeconnect-23.04.0-telephony-optional.patch
@@ -0,0 +1,40 @@
+From 97e47efdf6626fa0ae282684ab50ee6fce67d642 Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heiko.becker@kde.org>
+Date: Mon, 20 Mar 2023 20:33:11 +0100
+Subject: [PATCH] Make mmtelephony plugin optional
+
+I see little purpose in pulling that stack in on a desktop computer,
+which doesn't even have a modem.
+---
+ plugins/CMakeLists.txt | 5 ++++-
+ plugins/mmtelephony/CMakeLists.txt | 1 -
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/plugins/CMakeLists.txt b/plugins/CMakeLists.txt
+index dda19398b..1e304b88e 100644
+--- a/plugins/CMakeLists.txt
++++ b/plugins/CMakeLists.txt
+@@ -39,7 +39,10 @@ if(NOT SAILFISHOS)
+ add_subdirectory(virtualmonitor)
+
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+- add_subdirectory(mmtelephony)
++ find_package(KF5ModemManagerQt ${KF5_MIN_VERSION})
++ if (TARGET KF5::ModemManagerQt)
++ add_subdirectory(mmtelephony)
++ endif()
+ endif()
+
+ if(NOT WIN32)
+diff --git a/plugins/mmtelephony/CMakeLists.txt b/plugins/mmtelephony/CMakeLists.txt
+index 1fd9afe1e..c792b4c7c 100644
+--- a/plugins/mmtelephony/CMakeLists.txt
++++ b/plugins/mmtelephony/CMakeLists.txt
+@@ -1,4 +1,3 @@
+-find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS ModemManagerQt)
+ set(debug_file_SRCS)
+ ecm_qt_declare_logging_category(
+ debug_file_SRCS HEADER plugin_mmtelephony_debug.h
+--
+GitLab
+
diff --git a/kde-misc/kdeconnect/kdeconnect-23.04.0-r1.ebuild b/kde-misc/kdeconnect/kdeconnect-23.04.0-r1.ebuild
new file mode 100644
index 000000000000..83f731cb0357
--- /dev/null
+++ b/kde-misc/kdeconnect/kdeconnect-23.04.0-r1.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+KDE_ORG_NAME="${PN}-kde"
+KDE_SELINUX_MODULE="${PN}"
+KFMIN=5.104.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Adds communication between KDE Plasma and your smartphone"
+HOMEPAGE="https://kdeconnect.kde.org/ https://apps.kde.org/kdeconnect/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="bluetooth pulseaudio telephony X"
+
+RESTRICT="test"
+
+DEPEND="
+ >=app-crypt/qca-2.3.0:2[qt5(+),ssl]
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=
+ >=dev-qt/qtmultimedia-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=dev-qt/qtwayland-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtx11extras-${QTMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kirigami-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kpeople-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/plasma-${KFMIN}:5
+ >=kde-frameworks/qqc2-desktop-style-${KFMIN}:5
+ >=kde-frameworks/solid-${KFMIN}:5
+ x11-libs/libxkbcommon
+ bluetooth? ( >=dev-qt/qtbluetooth-${QTMIN}:5 )
+ pulseaudio? ( media-libs/pulseaudio-qt:= )
+ telephony? ( >=kde-frameworks/modemmanager-qt-${KFMIN}:5 )
+ X? (
+ x11-libs/libfakekey
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/kpeoplevcard
+ >=dev-qt/qtgraphicaleffects-${QTMIN}:5
+ >=dev-qt/qtmultimedia-${QTMIN}:5[qml]
+ >=kde-frameworks/kdeclarative-${KFMIN}:5
+ net-fs/sshfs
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-21.07.80-revert-disable-kpeople.patch"
+ "${FILESDIR}/${PN}-23.04.0-telephony-optional.patch" # bug 904823
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBLUETOOTH_ENABLED=$(usex bluetooth)
+ $(cmake_use_find_package pulseaudio KF5PulseAudioQt)
+ $(cmake_use_find_package telephony KF5ModemManagerQt)
+ $(cmake_use_find_package X LibFakeKey)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+
+ elog "The Android .apk file is available via"
+ elog "https://play.google.com/store/apps/details?id=org.kde.kdeconnect_tp"
+ elog "or via"
+ elog "https://f-droid.org/packages/org.kde.kdeconnect_tp/"
+}
diff --git a/kde-misc/kdeconnect/metadata.xml b/kde-misc/kdeconnect/metadata.xml
index e2d036edeeab..f2331e3e263e 100644
--- a/kde-misc/kdeconnect/metadata.xml
+++ b/kde-misc/kdeconnect/metadata.xml
@@ -11,6 +11,7 @@
</upstream>
<use>
<flag name="pulseaudio">Enable system volume control plugin using <pkg>media-sound/pulseaudio</pkg></flag>
+ <flag name="telephony">Enable telephony plugin using <pkg>kde-frameworks/modemmanager-qt</pkg></flag>
<flag name="X">Enable remote input mousepad plugin using <pkg>x11-libs/libfakekey</pkg></flag>
</use>
</pkgmetadata>