summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-12-28 16:27:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-28 16:28:41 +0100
commit8488e8b67650bf8295a85cdaa9a1911fd4cf8ac1 (patch)
tree3ad915bc8e556d5317982519b6e330eb08222960 /kde-frameworks
parentsci-geosciences/osm2pgsql: drop 1.4.0-r100 (diff)
downloadgentoo-8488e8b67650bf8295a85cdaa9a1911fd4cf8ac1.tar.gz
gentoo-8488e8b67650bf8295a85cdaa9a1911fd4cf8ac1.tar.bz2
gentoo-8488e8b67650bf8295a85cdaa9a1911fd4cf8ac1.zip
kde-frameworks/kservice: Drop applications.menu compat symlink
Follow-up to bb85aa585f4b421dc6475acca242b70a98a413f5 - sufficient time has passed. Bug: https://bugs.gentoo.org/596316 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kservice/kservice-5.116.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/kservice/kservice-5.116.0-r1.ebuild b/kde-frameworks/kservice/kservice-5.116.0-r1.ebuild
new file mode 100644
index 000000000000..8cfc1f60524f
--- /dev/null
+++ b/kde-frameworks/kservice/kservice-5.116.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Advanced plugin and service introspection"
+
+LICENSE="LGPL-2 LGPL-2.1+"
+KEYWORDS="amd64 ~arm arm64 ~loong ppc64 ~riscv x86"
+IUSE="+man"
+
+# requires running kde environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qtconcurrent-${QTMIN}:5 )
+"
+BDEPEND="
+ app-alternatives/lex
+ app-alternatives/yacc
+ man? ( >=kde-frameworks/kdoctools-${PVCUT}:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DAPPLICATIONS_MENU_NAME=kf5-applications.menu
+ $(cmake_use_find_package man KF5DocTools)
+ )
+
+ ecm_src_configure
+}