summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 17:45:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 17:46:10 +0100
commit6236777c9eb031d4637ea86950202248a1ab37eb (patch)
tree1b9178c968cd1e28eeab6a180566c5a50236c915 /kde-frameworks
parentdev-python/typeguard: Bump to 3.0.2 (diff)
downloadgentoo-6236777c9eb031d4637ea86950202248a1ab37eb.tar.gz
gentoo-6236777c9eb031d4637ea86950202248a1ab37eb.tar.bz2
gentoo-6236777c9eb031d4637ea86950202248a1ab37eb.zip
kde-frameworks/kio: Also handle copy_file_range failing with ENOENT
Bug: https://bugs.gentoo.org/885793 Bug: https://bugs.gentoo.org/899706 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/kio/files/kio-5.104.0-handle-copy_file_range-failing-w-ENOENT.patch33
-rw-r--r--kde-frameworks/kio/kio-5.104.0-r2.ebuild94
2 files changed, 127 insertions, 0 deletions
diff --git a/kde-frameworks/kio/files/kio-5.104.0-handle-copy_file_range-failing-w-ENOENT.patch b/kde-frameworks/kio/files/kio-5.104.0-handle-copy_file_range-failing-w-ENOENT.patch
new file mode 100644
index 000000000000..ae10923bb774
--- /dev/null
+++ b/kde-frameworks/kio/files/kio-5.104.0-handle-copy_file_range-failing-w-ENOENT.patch
@@ -0,0 +1,33 @@
+From 05dee56f45dae37745f21a95e19a149b69e719e3 Mon Sep 17 00:00:00 2001
+From: Fabian Vogt <fabian@ritter-vogt.de>
+Date: Mon, 27 Feb 2023 09:30:05 +0100
+Subject: [PATCH] Also handle copy_file_range failing with ENOENT
+
+There appears to be a kernel bug (?) that CIFS fails with ENOENT on
+copy_file_range.
+
+coreutils had to work around this as well, see the included link.
+
+(cherry picked from commit 00840d05abd875e1901b655ed6af3bc76ef48433)
+---
+ src/ioslaves/file/file_unix.cpp | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/src/ioslaves/file/file_unix.cpp b/src/ioslaves/file/file_unix.cpp
+index 1865b852d9..8d005daf81 100644
+--- a/src/ioslaves/file/file_unix.cpp
++++ b/src/ioslaves/file/file_unix.cpp
+@@ -822,7 +822,9 @@ void FileProtocol::copy(const QUrl &srcUrl, const QUrl &destUrl, int _mode, JobF
+ const ssize_t copiedBytes = ::copy_file_range(srcFile.handle(), nullptr, destFile.handle(), nullptr, s_maxIPCSize, 0);
+
+ if (copiedBytes == -1) {
+- if (errno == EINVAL || errno == EXDEV) {
++ // ENOENT is returned on cifs in some cases, probably a kernel bug
++ // (s.a. https://git.savannah.gnu.org/cgit/coreutils.git/commit/?id=7fc84d1c0f6b35231b0b4577b70aaa26bf548a7c)
++ if (errno == EINVAL || errno == EXDEV || errno == ENOENT) {
+ break; // will continue with next copy mechanism
+ }
+
+--
+GitLab
+
diff --git a/kde-frameworks/kio/kio-5.104.0-r2.ebuild b/kde-frameworks/kio/kio-5.104.0-r2.ebuild
new file mode 100644
index 000000000000..4734831d6e8a
--- /dev/null
+++ b/kde-frameworks/kio/kio-5.104.0-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_DESIGNERPLUGIN="true"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org xdg-utils
+
+DESCRIPTION="Framework providing transparent file and data management"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="acl +handbook kerberos +kwallet X"
+
+# tests hang
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5[ssl]
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ =kde-frameworks/kauth-${PVCUT}*:5
+ =kde-frameworks/karchive-${PVCUT}*:5
+ =kde-frameworks/kbookmarks-${PVCUT}*:5
+ =kde-frameworks/kcodecs-${PVCUT}*:5
+ =kde-frameworks/kcompletion-${PVCUT}*:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/kcrash-${PVCUT}*:5
+ =kde-frameworks/kdbusaddons-${PVCUT}*:5
+ =kde-frameworks/kguiaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/kitemviews-${PVCUT}*:5
+ =kde-frameworks/kjobwidgets-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/ktextwidgets-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+ =kde-frameworks/kwindowsystem-${PVCUT}*:5[X?]
+ =kde-frameworks/kxmlgui-${PVCUT}*:5
+ =kde-frameworks/solid-${PVCUT}*:5
+ acl? (
+ sys-apps/attr
+ virtual/acl
+ )
+ handbook? ( =kde-frameworks/kdoctools-${PVCUT}*:5 )
+ kerberos? ( virtual/krb5 )
+ kwallet? ( =kde-frameworks/kwallet-${PVCUT}*:5 )
+ X? ( >=dev-qt/qtx11extras-${QTMIN}:5 )
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ test? ( sys-libs/zlib )
+"
+PDEPEND=">=kde-frameworks/kded-${PVCUT}:5"
+
+PATCHES=(
+ "${FILESDIR}/${P}-renamefiledialog-fix-number-limit.patch" # KDE-bug 466636
+ "${FILESDIR}/${P}-handle-copy_file_range-failing-w-ENOENT.patch" # bug 885793
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DKIO_NO_PUBLIC_QTCONCURRENT=ON
+ $(cmake_use_find_package acl ACL)
+ $(cmake_use_find_package handbook KF5DocTools)
+ $(cmake_use_find_package kerberos GSSAPI)
+ $(cmake_use_find_package kwallet KF5Wallet)
+ -DWITH_X11=$(usex X)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ ecm_pkg_postinst
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ ecm_pkg_postrm
+ xdg_desktop_database_update
+}