summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-11 08:29:06 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-11 12:59:49 +0200
commitd072969be147a8bcceb1ac8281af2b77f76696f6 (patch)
tree8514c9373243e11fb8c024f2976639625f04aae7 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.87.0 version bump (diff)
downloadgentoo-d072969be147a8bcceb1ac8281af2b77f76696f6.tar.gz
gentoo-d072969be147a8bcceb1ac8281af2b77f76696f6.tar.bz2
gentoo-d072969be147a8bcceb1ac8281af2b77f76696f6.zip
kde-frameworks/purpose: 5.87.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.87.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index c1a9544386d2..ab41b8a62f67 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
DIST purpose-5.85.0.tar.xz 161412 BLAKE2B c6d55396ebde4f8b3f08a71c429bce4f0bbfe1303907d06faf841ab53147a78b582bd63e4b731eb6c5d16b939dade6dab2ca30930a9fa31babb9c1b68c37e53e SHA512 30da8286d7eb8b0652656d0c52fe0f95dd4c3c1f86e468af5f9b546b0afc996dbf9f3a0e011376de5b58e34bf529faca9f3add7ee0e820ab693745c98e21b1ed
DIST purpose-5.86.0.tar.xz 161844 BLAKE2B d0c8fc27012e2809de65f36f84355d11b484912e5bbfe32508ea4811fcb070cd614932b48efb5d7e9809d515947aa278742dbe8984c9de46de9526ab76445d0b SHA512 64a51a739fcbab8b9810a112a35c1fd217c0afc0baf5819e2ffd80594523fcab27cfd43e8957a310927757651f6bbfeb258f1a486cf7cf0c5394ad91b2304327
+DIST purpose-5.87.0.tar.xz 165172 BLAKE2B 8cd6954e9e518251f9b47c8d78d1e2573a6e52c16bbbbe0899f0023afd0acfac370f6d7fa09d7093c6f0269571f05792b25292590c2b3c294d2d43da57becbad SHA512 87a181c0d8d783684ba80e160ba57da48810c389a393f47f9e6017bd77d01d71b079375777fc89f2e61f964e50aeb0151085d86b9d8ae221572b9f477e523886
diff --git a/kde-frameworks/purpose/purpose-5.87.0.ebuild b/kde-frameworks/purpose/purpose-5.87.0.ebuild
new file mode 100644
index 000000000000..8f61c83816a7
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.87.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+inherit ecm kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}