summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-08 23:50:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-09 17:49:59 +0100
commit92ce08d47d7105b5d7a8c7140798a277b9b844ea (patch)
tree41bca5c9474de6cec35e12d8490260764da53970 /kde-frameworks/kwindowsystem
parentkde5-functions: Raise QT_MINIMAL to 5.11.1 (diff)
downloadgentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.tar.gz
gentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.tar.bz2
gentoo-92ce08d47d7105b5d7a8c7140798a277b9b844ea.zip
kde-frameworks: Add KDE Frameworks 5.53.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwindowsystem')
-rw-r--r--kde-frameworks/kwindowsystem/Manifest1
-rw-r--r--kde-frameworks/kwindowsystem/kwindowsystem-5.53.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/kde-frameworks/kwindowsystem/Manifest b/kde-frameworks/kwindowsystem/Manifest
index 354f459ed2ad..7a5ed7d2763b 100644
--- a/kde-frameworks/kwindowsystem/Manifest
+++ b/kde-frameworks/kwindowsystem/Manifest
@@ -1 +1,2 @@
DIST kwindowsystem-5.52.0.tar.xz 169764 BLAKE2B 986cc65ec3d3eb9bf22181b1acac817dcd932762c7a807b166f8c8775df182b7a87a69e17a8df73c60336919775ad377a6a3a2d51f50e95383e8e2722ddd37e1 SHA512 fa24a29cc814c226cb3f80784f8e07ffdcfe77e03ad3f010ea0b9da3365ca24416c3f3d920fdc557688c3a5a1465cdb946a8dde7962b3bc15dca0a58785fc098
+DIST kwindowsystem-5.53.0.tar.xz 169740 BLAKE2B 9b9cbea9a3028b8e9e30c1139cce609d2a14aceaf9e2bfe8f27343e18e7c740e05e48b12280540144d84529c1b4bd65b9772920c8fcfc6172afeb0464bb76617 SHA512 5032629e1af3cf4c0704e8a7d9751dba538d6bca3a6553e1f22cd1d9b7a7d5d62b4ba851f870d98bfae3344b4f99f45883fa8d05a0f8d93ecc91ec28bb676417
diff --git a/kde-frameworks/kwindowsystem/kwindowsystem-5.53.0.ebuild b/kde-frameworks/kwindowsystem/kwindowsystem-5.53.0.ebuild
new file mode 100644
index 000000000000..56f417f3568d
--- /dev/null
+++ b/kde-frameworks/kwindowsystem/kwindowsystem-5.53.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework providing access to properties and features of the window manager"
+LICENSE="|| ( LGPL-2.1 LGPL-3 ) MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="nls X"
+
+RDEPEND="
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ )
+"
+DEPEND="${RDEPEND}
+ nls? ( $(add_qt_dep linguist-tools) )
+ X? ( x11-base/xorg-proto )
+"
+
+RESTRICT+=" test"
+
+DOCS=( "docs/README.kstartupinfo" )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X X11)
+ )
+
+ kde5_src_configure
+}