summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 10:27:41 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-08 14:03:48 +0200
commit64aa333e5583d97e0c79fbaab9e0d081306746c7 (patch)
treeafc45113905a61843b091a2cea9bc284100a34be /kde-frameworks/kwayland/kwayland-5.50.0.ebuild
parentkde-apps/kpat: Add FRAMEWORKS_MINIMAL,QT_MINIMAL defs (diff)
downloadgentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.gz
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.tar.bz2
gentoo-64aa333e5583d97e0c79fbaab9e0d081306746c7.zip
kde-frameworks: Add KDE Frameworks 5.50.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.50.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.50.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.50.0.ebuild b/kde-frameworks/kwayland/kwayland-5.50.0.ebuild
new file mode 100644
index 000000000000..4bc9d6baa35e
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.50.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+inherit kde5
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://cgit.kde.org/kwayland.git"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtgui 'egl')
+ >=dev-libs/wayland-1.13.0
+ media-libs/mesa[egl]
+"
+RDEPEND="${DEPEND}
+ $(add_qt_dep qtwayland 'egl(+)')
+"
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT+=" test"