summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-05-13 18:35:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-05-13 18:55:12 +0200
commita44ff064f72ebfacc5fc864f498adb3e8b800733 (patch)
tree8fcd2f765277b02a4f1058cb559747bf9b17c316 /kde-frameworks/frameworkintegration
parentnet-libs/libssh: drop 0.10.4 (diff)
downloadgentoo-a44ff064f72ebfacc5fc864f498adb3e8b800733.tar.gz
gentoo-a44ff064f72ebfacc5fc864f498adb3e8b800733.tar.bz2
gentoo-a44ff064f72ebfacc5fc864f498adb3e8b800733.zip
kde-frameworks/frameworkintegration: 5.106.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.106.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 4ab34ba658ed..d592fd9c9950 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.104.0.tar.xz 1759964 BLAKE2B 83dbd951eefea03d8ad544a7f1ca1e39609ec7ed565b17c02a40ce3be795cc8386593fea09727a041e4ddec41dd795a7642901a24c8cdfc955a8cca5f77d9254 SHA512 2c5130b555b93cb72ce36be3708868fd35ebcda0a226e5099efe337477d53f938f066fd35a7e90efddadd3a51f427810b1b412028bbe6222e9208915afa06a74
DIST frameworkintegration-5.105.0.tar.xz 1759984 BLAKE2B 48490f21bb785be66a3c3363d1a45594c6f629b4d13743ebd438c5fd204473cf29e126d66f01532eb40bf51e10a340506df1e0a6539ce8926c6693ad2f9b3d0d SHA512 ecb819d332864e34b6dd0273afec417135a5c1ea7cbdea2bad9bf33b03eef231df50edb4e6296ed6f04f036746839af45992606a83609f4899944ce69326f839
+DIST frameworkintegration-5.106.0.tar.xz 1759984 BLAKE2B e0de31798596cb8b2abb23938bc27c90bf7c898eacc666940a75dcb2adf2e99afb048afbba6b756b25a64f525cf19c129e4783cbd0a2479d2737dd917897a8e4 SHA512 bf0baafcdda7ecd9f66501a1585af3c6bc8417c17168ee11883bfe9096bb00f0a93313c246296bfdc096c230ff35d4f3fc223da7cba875aca2978b42b6bb5cb5
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.106.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.106.0.ebuild
new file mode 100644
index 000000000000..c90c2445d25f
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.106.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+VIRTUALX_REQUIRED="test"
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}