summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-09-15 04:04:32 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-09-15 04:12:16 +1000
commit1f9700ed2ec8463a6b7d80a06f83c7b50c973b54 (patch)
tree4a5042f5e2915e29ee83096ce0306f8e0e8208ee /kde-frameworks/frameworkintegration
parentdev-python/simplecv: remove unused patch (diff)
downloadgentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.tar.gz
gentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.tar.bz2
gentoo-1f9700ed2ec8463a6b7d80a06f83c7b50c973b54.zip
kde-frameworks: version bump 5.26.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.26.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 832a6bd9fffe..2e6d82576046 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.23.0.tar.xz 1749136 SHA256 48b472cbdfc2407b68247dc40bcee8b6e9f951c2e20f97030c68f95f7d283b28 SHA512 d743400189fa9ab3d7ac3c638942995fe25600c7b91c645316224125c64bb86a7bdd9beeb4d833050e137dceb3ef7f674cb56faaf914966bd209bf207a7c5043 WHIRLPOOL 26b78e07f97e69011db3a04feeca26d02971e2b8c5a63562e958aead61a5ecf40bad850f4e734d9364497febfb049276a37458a218eeedcd379e656bbae38143
DIST frameworkintegration-5.25.0.tar.xz 1749232 SHA256 ea9ccb564aa1cebdd7ad3dbd5168cb1ae750f20122918864d846990828057653 SHA512 28fcf78d28b662885a7f63ba5ebf316439e192864f058110e347330d4ff2f73ec66a5f602b725777db0ac3b8e86aff63763c325c051c64fba7c220473f47ffb7 WHIRLPOOL 47515f89bcc242a7ad603a833fbde149f3c53f9105eab8006f665e417c31f6fa1148e1b18ad684dc2b3c0bfc45d2da02b867f2620533032fed053f7e1856cf2a
+DIST frameworkintegration-5.26.0.tar.xz 1749228 SHA256 374db7d9b69486aa16fccf1391869f058679bf2aa7adf6f109ba29d3f4e31653 SHA512 a3211cff802a0d616d45952659c03cd515c4318b329344dc3b93eb2d2dfcc877fbe07cc88d96f1cf5c0184c596bce733593f5b97fe7bb8c6453643207111386a WHIRLPOOL 0fcc5e6f5b0b3272ddd8faea68396781f7c91325fa457f23a9196e3505c5e239b857849083b0e30a482e23340dff220f039cdf105c703157759a44aade33d00f
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.26.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.26.0.ebuild
new file mode 100644
index 000000000000..14bdd104a79e
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.26.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}