summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:13:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-05-11 23:46:08 +0200
commit2de492f66f593f97c84056a21259aaa5653681dd (patch)
treefe20d10d8a88b87b3b6ef55c8ac06f5b3621c0f0 /kde-apps/spectacle
parentkde5.eclass: Disable kdoctools_install(po) if KDE_HANDBOOK=forceoptional (diff)
downloadgentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.gz
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.tar.bz2
gentoo-2de492f66f593f97c84056a21259aaa5653681dd.zip
kde-apps: Add KDE Applications 17.04.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-apps/spectacle')
-rw-r--r--kde-apps/spectacle/Manifest1
-rw-r--r--kde-apps/spectacle/spectacle-17.04.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-apps/spectacle/Manifest b/kde-apps/spectacle/Manifest
index 4f09daa3cd85..5cb7e65b2da7 100644
--- a/kde-apps/spectacle/Manifest
+++ b/kde-apps/spectacle/Manifest
@@ -1,2 +1,3 @@
DIST spectacle-16.12.3.tar.xz 1006712 SHA256 a64fa9f748e41ad63b65039aa447faf1bcdb418da0a1f81366f1e95454388ab9 SHA512 6f27f14e28bf1cfc2e6cf7e1fd11784163c8ce6ec63bded583c9b86a549891b8de806e7874cea756ea7616d0ac650695038e85282a2bc9fe32568be19c8cbb99 WHIRLPOOL 128ca2a1b314a4e033435da1c5fa0acb4a58d983101b338f1ba9ff240626746912824df0949a20ab70bc35509b2e556561fc0905a52bccf7b5e4dd38946edbb6
DIST spectacle-17.04.0.tar.xz 2064124 SHA256 1e7cc028fc1d3845f0cf03aadbd4423393b14c562d0d97c84bd2b9a8d7f6b56e SHA512 144b396940050fdb6e1faf6f4202c6a1ee83996d1187024c225368c3b77cef03690acdd40a0c9db96e37271e9198279da37eb9b13d9242d77c274aad87cbdd8c WHIRLPOOL 6791346778abafa830583114f9eab48f2d684ac61a9f712b99bb9e2f420518fca008d78effc24d2d9691e582b747e4f15ba1045d9d42da4120e1c3c4c4604d5c
+DIST spectacle-17.04.1.tar.xz 2063980 SHA256 5cea11dcb8c6b17e23944801b81634cd838627cb36a0e11442b75eda8761ec4b SHA512 4a2c8fbea2bd4057b63d895eacf1ae28c0f02d52535f2cee4634c8257bb6d9bb0b73f4798525d5c6a9b6c256afa3691664111407a3dfc6c9f670997b387a4111 WHIRLPOOL a3b49665b595ec1b56baec0830a4509317632bca550ef08ab16ac8a5c8263fe5d19f48645e6d61d1af44500d1801a7b59b60c9dc5e8aff101613db034bea05d5
diff --git a/kde-apps/spectacle/spectacle-17.04.1.ebuild b/kde-apps/spectacle/spectacle-17.04.1.ebuild
new file mode 100644
index 000000000000..5f892af2e50c
--- /dev/null
+++ b/kde-apps/spectacle/spectacle-17.04.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+inherit kde5
+
+DESCRIPTION="Screenshot capture utility"
+LICENSE="LGPL-2+ handbook? ( FDL-1.3 ) kipi? ( GPL-2+ )"
+KEYWORDS="~amd64 ~x86"
+IUSE="kipi share"
+
+DEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep kdeclarative)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-image
+ kipi? ( $(add_kdeapps_dep libkipi '' '' '5=') )
+ share? ( dev-libs/purpose:5 )
+"
+RDEPEND="${DEPEND}
+ kipi? ( media-plugins/kipi-plugins:5 )
+ !kde-apps/ksnapshot
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kipi KF5Kipi)
+ $(cmake-utils_use_find_package share KDEExperimentalPurpose)
+ )
+ kde5_src_configure
+}