summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-12-15 13:36:28 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-12-15 13:42:08 +0100
commit2f280a59b1dbd4ce4dda3631a6824332fb814303 (patch)
tree514a9d4b9e370f3195f973602dbe99a96fcf78a1 /kde-apps/marble/files
parentdev-ruby/activesupport: Stabilize 6.1.7.10 sparc, #946498 (diff)
downloadgentoo-2f280a59b1dbd4ce4dda3631a6824332fb814303.tar.gz
gentoo-2f280a59b1dbd4ce4dda3631a6824332fb814303.tar.bz2
gentoo-2f280a59b1dbd4ce4dda3631a6824332fb814303.zip
kde-apps/marble: Fix build with USE="-kde"
See also: https://invent.kde.org/education/marble/-/merge_requests/148 https://invent.kde.org/education/marble/-/merge_requests/149 Closes: https://bugs.gentoo.org/946470 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/marble/files')
-rw-r--r--kde-apps/marble/files/marble-24.12.0-cmake-behaim-marble-maps-kf6-conditional.patch29
-rw-r--r--kde-apps/marble/files/marble-24.12.0-cmake-drop-qt_policy.patch69
2 files changed, 98 insertions, 0 deletions
diff --git a/kde-apps/marble/files/marble-24.12.0-cmake-behaim-marble-maps-kf6-conditional.patch b/kde-apps/marble/files/marble-24.12.0-cmake-behaim-marble-maps-kf6-conditional.patch
new file mode 100644
index 000000000000..3db739a8c82b
--- /dev/null
+++ b/kde-apps/marble/files/marble-24.12.0-cmake-behaim-marble-maps-kf6-conditional.patch
@@ -0,0 +1,29 @@
+From 5a6bf3c71cd017f3e43a74d9ac39efa3921c6d99 Mon Sep 17 00:00:00 2001
+From: Joshua Goins <josh@redstrate.com>
+Date: Sat, 14 Dec 2024 20:18:24 -0500
+Subject: [PATCH] Don't build behaim or marble-maps targets in non-KF builds
+
+These depend on KDE frameworks, so don't try to build them when don't
+have them.
+---
+ src/apps/CMakeLists.txt | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/src/apps/CMakeLists.txt b/src/apps/CMakeLists.txt
+index 6f9dc25420..013cd3c52f 100644
+--- a/src/apps/CMakeLists.txt
++++ b/src/apps/CMakeLists.txt
+@@ -11,6 +11,8 @@ if(BUILD_MARBLE_APPS)
+ endif()
+ endif()
+
+- add_subdirectory(behaim)
+- add_subdirectory(marble-maps)
++ if (TARGET KF6::Config AND TARGET KF6::I18n AND TARGET KF6::CoreAddons)
++ add_subdirectory(behaim)
++ add_subdirectory(marble-maps)
++ endif()
+ endif()
+--
+GitLab
+
diff --git a/kde-apps/marble/files/marble-24.12.0-cmake-drop-qt_policy.patch b/kde-apps/marble/files/marble-24.12.0-cmake-drop-qt_policy.patch
new file mode 100644
index 000000000000..71f721043c4d
--- /dev/null
+++ b/kde-apps/marble/files/marble-24.12.0-cmake-drop-qt_policy.patch
@@ -0,0 +1,69 @@
+From 98d2d37dcec8ec8b5b7f4c24c85120ed9468a33a Mon Sep 17 00:00:00 2001
+From: Joshua Goins <josh@redstrate.com>
+Date: Sat, 14 Dec 2024 20:08:44 -0500
+Subject: [PATCH] Remove usage of some Qt CMake usage with ECMQmlModule
+
+We use this, so we don't need to set qt_policy ourselves or
+ecm_add_qml_module. Also fixes non-KF6 builds.
+---
+ CMakeLists.txt | 2 --
+ examples/cpp/marbleQuick2/CMakeLists.txt | 2 +-
+ src/apps/behaim/CMakeLists.txt | 2 +-
+ src/apps/marble-maps/CMakeLists.txt | 2 +-
+ 4 files changed, 3 insertions(+), 5 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 0681500d06..f708cacd52 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -110,8 +110,6 @@ set_package_properties(KF6 PROPERTIES
+ TYPE RECOMMENDED
+ )
+
+-qt_policy(SET QTP0001 NEW)
+-
+ find_package(Protobuf)
+ set_package_properties(Protobuf PROPERTIES TYPE OPTIONAL PURPOSE "Parsing of OSM PBF files.")
+
+diff --git a/examples/cpp/marbleQuick2/CMakeLists.txt b/examples/cpp/marbleQuick2/CMakeLists.txt
+index c9c3809e85..493684f409 100644
+--- a/examples/cpp/marbleQuick2/CMakeLists.txt
++++ b/examples/cpp/marbleQuick2/CMakeLists.txt
+@@ -5,7 +5,7 @@ add_executable(marbleQuick2 main.cpp)
+
+ target_link_libraries(marbleQuick2 PUBLIC Qt::Quick Qt::Widgets)
+
+-qt_add_qml_module(marbleQuick2
++ecm_add_qml_module(marbleQuick2
+ URI org.kde.marble.quick
+ QML_FILES
+ Main.qml
+diff --git a/src/apps/behaim/CMakeLists.txt b/src/apps/behaim/CMakeLists.txt
+index 8011e0bc52..13219b663a 100644
+--- a/src/apps/behaim/CMakeLists.txt
++++ b/src/apps/behaim/CMakeLists.txt
+@@ -19,7 +19,7 @@ if(NOT MARBLE_NO_WEBKITWIDGETS)
+ add_definitions(-DMARBLE_WEBKITWIDGETS=1)
+ endif()
+
+-qt_add_qml_module(marble-behaim
++ecm_add_qml_module(marble-behaim
+ URI org.kde.marble.behaim
+ QML_FILES
+ MainScreen.qml
+diff --git a/src/apps/marble-maps/CMakeLists.txt b/src/apps/marble-maps/CMakeLists.txt
+index 39f9940322..79a4897304 100644
+--- a/src/apps/marble-maps/CMakeLists.txt
++++ b/src/apps/marble-maps/CMakeLists.txt
+@@ -22,7 +22,7 @@ if(NOT ANDROID)
+ target_link_libraries(marble-maps PUBLIC KF6::Crash)
+ endif()
+
+-qt_add_qml_module(marble-maps
++ecm_add_qml_module(marble-maps
+ URI org.kde.marble.maps
+ QML_FILES
+ MainScreen.qml
+--
+GitLab
+