summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-11-15 20:38:29 +0100
committerJohannes Huber <johu@gentoo.org>2016-11-15 20:47:49 +0100
commite805750640ffcd5150e817e77162f388021b8c0f (patch)
tree8c53c84f54ac00f079d48833e5fbc02a3937b525 /kde-apps/cantor
parentsys-devel/gcc: mark 4.9.4 arm64/ia64/m68k/ppc/s390/sh/sparc stable #595560 (diff)
downloadgentoo-e805750640ffcd5150e817e77162f388021b8c0f.tar.gz
gentoo-e805750640ffcd5150e817e77162f388021b8c0f.tar.bz2
gentoo-e805750640ffcd5150e817e77162f388021b8c0f.zip
kde-apps: Version bump KDE Applications 16.08.3
Package-Manager: portage-2.3.2
Diffstat (limited to 'kde-apps/cantor')
-rw-r--r--kde-apps/cantor/Manifest1
-rw-r--r--kde-apps/cantor/cantor-16.08.3.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/kde-apps/cantor/Manifest b/kde-apps/cantor/Manifest
index 7830c8c61a74..44e384657202 100644
--- a/kde-apps/cantor/Manifest
+++ b/kde-apps/cantor/Manifest
@@ -1,2 +1,3 @@
DIST cantor-16.04.3.tar.xz 351024 SHA256 eae03b97912a193ebe2207f45dcd581ab537ef6c5feb849492fb95dec2aa0cd7 SHA512 01f8cd1ed1209a182ad798dbdaaebf5fd8cf4a29459b8bcb605108cf44382c49757ab94189080ebdca0c9c1de6036f7c9bfd4ba68c2171aff245124cf0074a5c WHIRLPOOL 7ff4ce453762885d4dca27e272e9082f45897a94b1fe11b3c844d27f9a07ae703e867d28ea665a8212218d79a91b37f34c19465b82cb31e9ea8a1f3a7b80448b
DIST cantor-16.08.2.tar.xz 361340 SHA256 4c6ed7722d280b6dce60319bae5a6ace07acd6cd407f213dd098703a5d4229fe SHA512 0e2f4e319de199ed8de36fef4c4a2ecb44726ccfc11e5e4e5ba577d8112b97ab8052cbd2b4ee2520079f277383f92ecab625a0987a0b02406bbd67bcc84b48b7 WHIRLPOOL 603a0af67506855933ee6c01d507909e09899207126b6a57fb8aa8e708d4820718549db634ecd41a1f573faf4b6b3b8e759ea75a635d33ad870c71aaae6c97e8
+DIST cantor-16.08.3.tar.xz 361368 SHA256 c702f5f94b68bc18414c3f193b93f431cb2063da9ce41c089478b77337695a44 SHA512 46ef9494ccc94bb849b551fa7b9e5a8bb43263ac5a5170d699ec9cfbace66ec56318ffa1b4c939cdb1e7887d5b6b8061a9361e6171a8decd7deb4079c45511d2 WHIRLPOOL fc11c8ed444fd2c61f49c54cd389fc640c14d43c91e6cd0e3ca89f81a4cff82ea4429b9428a6c92110f4111ff261c4b09faab4c311e8b8835ef7a3a955838350
diff --git a/kde-apps/cantor/cantor-16.08.3.ebuild b/kde-apps/cantor/cantor-16.08.3.ebuild
new file mode 100644
index 000000000000..d5fb0a628ea9
--- /dev/null
+++ b/kde-apps/cantor/cantor-16.08.3.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="forceoptional"
+PYTHON_COMPAT=( python2_7 )
+# FIXME: PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit kde5 python-r1
+
+DESCRIPTION="Interface for doing mathematics and scientific computing"
+HOMEPAGE="https://www.kde.org/applications/education/cantor https://edu.kde.org/cantor"
+KEYWORDS="~amd64 ~x86"
+IUSE="analitza lua postscript python qalculate +R"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
+# FIXME: $(python_gen_cond_dep 'dev-qt/qtdbus:5' 'python3*')
+RDEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kpty)
+ $(add_frameworks_dep ktexteditor)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ $(add_qt_dep qtxmlpatterns)
+ analitza? ( $(add_kdeapps_dep analitza) )
+ lua? ( dev-lang/luajit:2 )
+ qalculate? (
+ sci-libs/cln
+ sci-libs/libqalculate
+ )
+ postscript? ( app-text/libspectre )
+ python? ( ${PYTHON_DEPS} )
+ R? ( dev-lang/R )
+"
+DEPEND="${RDEPEND}
+ >=dev-cpp/eigen-2.0.3:2
+"
+
+RESTRICT="test"
+
+pkg_setup() {
+ use python && python_setup
+ kde5_pkg_setup
+}
+
+src_prepare() {
+ kde5_src_prepare
+
+ # FIXME: shipped FindPythonLibs3.cmake does not work for Gentoo
+ sed -e "/^find_package(PythonLibs3)/ s/^/#/" \
+ -i src/backends/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package analitza Analitza5)
+ $(cmake-utils_use_find_package lua LuaJIT)
+ $(cmake-utils_use_find_package postscript LibSpectre)
+ $(cmake-utils_use_find_package python PythonLibs)
+ $(cmake-utils_use_find_package qalculate Qalculate)
+ $(cmake-utils_use_find_package R R)
+ )
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! use analitza && ! use lua && ! use python && ! use qalculate && ! use R; then
+ echo
+ ewarn "You have decided to build ${PN} with no backend."
+ ewarn "To have this application functional, please do one of below:"
+ ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'analitza', 'lua', 'python', 'qalculate' or 'R' USE flag enabled"
+ ewarn " # emerge -vaDu sci-mathematics/maxima"
+ echo
+ fi
+}