summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-12-13 09:59:31 +0000
committerArthur Zamarin <arthurzam@gentoo.org>2024-12-13 10:14:47 +0000
commitfc0d0cfe113736b988852fa04616d6c3ab83b484 (patch)
tree3a78ba309744f2756254e7c24e36945a11cff617 /gui-libs
parentapp-editors/vscode: add 1.96.0 (diff)
downloadgentoo-fc0d0cfe113736b988852fa04616d6c3ab83b484.tar.gz
gentoo-fc0d0cfe113736b988852fa04616d6c3ab83b484.tar.bz2
gentoo-fc0d0cfe113736b988852fa04616d6c3ab83b484.zip
gui-libs/neatvnc: add 0.9.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/neatvnc/Manifest1
-rw-r--r--gui-libs/neatvnc/neatvnc-0.9.2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/gui-libs/neatvnc/Manifest b/gui-libs/neatvnc/Manifest
index dd41671c15c4..b505a8ac7999 100644
--- a/gui-libs/neatvnc/Manifest
+++ b/gui-libs/neatvnc/Manifest
@@ -1 +1,2 @@
DIST neatvnc-0.8.1.tar.gz 661911 BLAKE2B 7d17e14cef3af1de509387581ea632ef967a9a669f26b85adb7e0f3e725fbe15125faf85bf71e75f926cf3b1508eafe600fc4d2b937e34c738dae9427459fb05 SHA512 4c5701765ba78e8fbfff71054988760b5a705946798e709d6905e63ac457f4c2da72aa0866e3cb3832b9aff0722199c1fb52869373677310ba22620413ed6b03
+DIST neatvnc-0.9.2.tar.gz 826089 BLAKE2B f22f6aa53c5bc8b972ee9c9e4890462a4327480be024273ef27aed1af10229287bf3d5e2570047b062846ce3f150fd0aeb31e8e8c1954824d4869088af6e3adb SHA512 769dfa6afd389a11cd457326e693d3bb47b8d333404ba9574761dd16a15310545e3db55ff11d5c5123adac1f0b2cb2661ff6b1612a90abd9e6cd024e5bcb25e0
diff --git a/gui-libs/neatvnc/neatvnc-0.9.2.ebuild b/gui-libs/neatvnc/neatvnc-0.9.2.ebuild
new file mode 100644
index 000000000000..ac897a0a4e0d
--- /dev/null
+++ b/gui-libs/neatvnc/neatvnc-0.9.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Liberally licensed VNC server library with a clean interface"
+HOMEPAGE="https://github.com/any1/neatvnc/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
+else
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples gbm h264 jpeg ssl test tracing websockets"
+REQUIRED_USE="h264? ( gbm )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/aml-0.3*
+ sys-libs/zlib
+ x11-libs/pixman
+ examples? (
+ media-libs/libpng:=
+ )
+ gbm? ( media-libs/mesa )
+ h264? (
+ media-video/ffmpeg:=
+ x11-libs/libdrm
+ )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ ssl? ( net-libs/gnutls:= )
+ tracing? ( dev-debug/systemtap )
+ websockets? (
+ dev-libs/gmp:=
+ dev-libs/nettle:=[gmp]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libdrm
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # useful soname
+ sed -i -e "s/'0.0.0'/meson.project_version()/" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use test tests)
+ $(meson_feature jpeg)
+ $(meson_feature ssl tls)
+ $(meson_feature websockets nettle)
+ $(meson_use tracing systemtap)
+ $(meson_feature gbm)
+ $(meson_feature h264)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+
+ if use examples; then
+ newbin "${BUILD_DIR}"/examples/draw neatvnc-example-draw
+ newbin "${BUILD_DIR}"/examples/png-server neatvnc-example-png-server
+ fi
+}