summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-11-03 23:36:48 -0300
committerMatt Turner <mattst88@gentoo.org>2022-11-04 14:00:27 -0400
commit44af503ce23808466d18a9778ea2259f7d0c9401 (patch)
treedd09f2e214b6c792b079fe0a3461c8fa3c4a0c6a /gui-libs/tepl
parentgui-libs/amtk: Version bump to 5.6.0 (diff)
downloadgentoo-44af503ce23808466d18a9778ea2259f7d0c9401.tar.gz
gentoo-44af503ce23808466d18a9778ea2259f7d0c9401.tar.bz2
gentoo-44af503ce23808466d18a9778ea2259f7d0c9401.zip
gui-libs/tepl: Version bump to 6.2.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gui-libs/tepl')
-rw-r--r--gui-libs/tepl/Manifest1
-rw-r--r--gui-libs/tepl/tepl-6.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/gui-libs/tepl/Manifest b/gui-libs/tepl/Manifest
index 9e80abd67407..c4850b33c3e3 100644
--- a/gui-libs/tepl/Manifest
+++ b/gui-libs/tepl/Manifest
@@ -1,2 +1,3 @@
DIST tepl-5.0.1.tar.xz 126068 BLAKE2B 2c3038326660f6326c5030cb944f8cee885b794a481f6d8f1b5d87a8ea7121ded381d28b36246a99b57bbea5fd9e6d2d4f65f9dfc54d8154ee8aabbccd7e3cb5 SHA512 f363d182185976447d235cf1201148e5201cdabd1fa8b88d7a763a965896f87bd222a0161c11e93662afaf4e474bbd0308643d28559aadc27b9d48974f4c458d
DIST tepl-6.0.2.tar.xz 142916 BLAKE2B 584d4ccec446f94590020e569f1a2b28d4b10a2452479c2c521c05927a094d01b28d81e2271dc8f4e1aa0a66976df64cead357f5487f78944c20ceca5c542742 SHA512 8b12418ba9e18a3aa1772692d196583353d98d73a007b35d93d2c605efceb5064e556968e5612f326f6b447ced0cdd66c130b6840c98ec067e1ba7da930fa4b4
+DIST tepl-6.2.0.tar.xz 147960 BLAKE2B 6937e5cd8a863b29f21bcd36eadc6e617da061f22e82c971bf72de0f7f742534d84be85107866cf621266af95f4f4c0c9c2456631fe63d47fae02574d6223b65 SHA512 694264bfc2d984de37619ffec603387fb1ac5053377f1de2b6b0313e0739f9eacea07845c5bdaaea64a5cf185c6ab0987a115bb4def55d69861a06f06d2d3b13
diff --git a/gui-libs/tepl/tepl-6.2.0.ebuild b/gui-libs/tepl/tepl-6.2.0.ebuild
new file mode 100644
index 000000000000..ab01e1768d9d
--- /dev/null
+++ b/gui-libs/tepl/tepl-6.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson virtualx
+
+DESCRIPTION="GtkSourceView-based text editors and IDE helper library"
+HOMEPAGE="https://gitlab.gnome.org/swilmet/tepl"
+
+LICENSE="LGPL-3+"
+SLOT="6/1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection gtk-doc"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0:4[introspection?]
+ >=gui-libs/amtk-5.0:5=[introspection?]
+ dev-libs/icu:=
+ gnome-base/gsettings-desktop-schemas
+ introspection? ( >=dev-libs/gobject-introspection-1.42:= )
+"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.25
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ $(meson_use introspection gobject_introspection)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}