summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-01-18 17:25:30 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-01-18 17:27:08 +0100
commit7aa506ae510c2d4b55d64245f158d6f5b3b9823c (patch)
treefdaf2403ff51396571190cc5a842c38d2ad49ba8 /gui-apps/xwaylandvideobridge
parentmedia-sound/reaper-bin: add 7.09, drop 7.08-r1 (diff)
downloadgentoo-7aa506ae510c2d4b55d64245f158d6f5b3b9823c.tar.gz
gentoo-7aa506ae510c2d4b55d64245f158d6f5b3b9823c.tar.bz2
gentoo-7aa506ae510c2d4b55d64245f158d6f5b3b9823c.zip
gui-apps/xwaylandvideobridge: add 0.4.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'gui-apps/xwaylandvideobridge')
-rw-r--r--gui-apps/xwaylandvideobridge/Manifest1
-rw-r--r--gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.4.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/gui-apps/xwaylandvideobridge/Manifest b/gui-apps/xwaylandvideobridge/Manifest
index a49622eaaa0e..4428e599841f 100644
--- a/gui-apps/xwaylandvideobridge/Manifest
+++ b/gui-apps/xwaylandvideobridge/Manifest
@@ -1 +1,2 @@
DIST xwaylandvideobridge-0.3.0.tar.xz 35584 BLAKE2B 10d0770efc023a3c52bcc7af119d13cf2d38cd9c6d4d0e7a19a46ae455428a7b2fc03a8b61a8036a15210d699193c71784962c60ad82a65a385414b426c20e78 SHA512 9e86fac3dbed2c2cca1b899a8266c8feda3263544048c3e554e3029f065053637dda84fc0fcc10be5d4856015743b0cdcb8e0e18cd26d14739fb7481850b1392
+DIST xwaylandvideobridge-0.4.0.tar.xz 35668 BLAKE2B c21857821bfc16b5df14feeea2ea188cedb00f1f3634335a359ba0938b8fb50f5ccf914011f6aca5bd527740ea62297ba9e4171604147d10d87725a0b545d96b SHA512 d0352b7ce94f1a355d8fd8f42a45436483a87d90da1904295f984012859651472eabbca39df5107793790d48474b6de1c8766e31461d1548134547cbc7dfd5a4
diff --git a/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.4.0.ebuild b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.4.0.ebuild
new file mode 100644
index 000000000000..53b128d9b700
--- /dev/null
+++ b/gui-apps/xwaylandvideobridge/xwaylandvideobridge-0.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KFMIN=5.245.0
+QTMIN=6.6.0
+KDE_ORG_CATEGORY="system"
+inherit ecm kde.org
+
+DESCRIPTION="Screenshare Wayland windows to XWayland apps"
+HOMEPAGE="https://planet.kde.org/david-edmundson-2023-03-22-fixing-wayland-xwayland-screen-casting/
+https://invent.kde.org/system/xwaylandvideobridge"
+
+if [[ ${KDE_BUILD_TYPE} == release ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/knotifications-${KFMIN}:6
+ >=kde-frameworks/kstatusnotifieritem-${KFMIN}:6
+ >=kde-frameworks/kwindowsystem-${KFMIN}:6[X]
+ kde-plasma/kpipewire:6
+ media-libs/freetype
+ x11-libs/libxcb:=
+ x11-libs/xcb-util
+"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"