summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cinnamon-desktop
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cinnamon-desktop')
-rw-r--r--gnome-extra/cinnamon-desktop/Manifest3
-rw-r--r--gnome-extra/cinnamon-desktop/cinnamon-desktop-2.4.2.ebuild62
-rw-r--r--gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.4.ebuild81
-rw-r--r--gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.5.ebuild81
-rw-r--r--gnome-extra/cinnamon-desktop/files/cinnamon-desktop-2.6.4.systemd.gschema.override5
-rw-r--r--gnome-extra/cinnamon-desktop/metadata.xml8
6 files changed, 240 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-desktop/Manifest b/gnome-extra/cinnamon-desktop/Manifest
new file mode 100644
index 000000000000..9347c4221c48
--- /dev/null
+++ b/gnome-extra/cinnamon-desktop/Manifest
@@ -0,0 +1,3 @@
+DIST cinnamon-desktop-2.4.2.tar.gz 524074 SHA256 62e2ff4fad405f8d4e7259dbeb2daf65c6f8b9995f2bb1e595a7cc0c2a7f9e0a SHA512 a36c26c262de72c8380c4d399129d610657a1d3ff3a45e688156c60f21957deb7fafb6deaafb442d85cb3ceea2e3c57dd59cb67588804a1e60607d6dbc7e6088 WHIRLPOOL a58cf18725c1f8dafd43495328f4727471ec09c7b851a031022befc10cce1cd12f05df14f59a1be4ffad6c6715d43f6b2b3a22bb1e1158976a898e1ee6b1512e
+DIST cinnamon-desktop-2.6.4.tar.gz 528598 SHA256 d40fc57202408476ff0bfa191958f16de07cf4c00d911bef57c3107c8e483970 SHA512 053cfad14a0ccd1dccb10128ba9c8b7199bb73794ddff83eb5565159acd8cb6f1c02df861a3757b78f03c47a7af1b4b47441ca486d24ff181f9687b1283e8437 WHIRLPOOL 639ac92935ceef2552f488280046cf9d548af9a3cdee66ec8a5784453b82a20445cd0c04636adebeb72198d1ef372d597985bcd9d52bc7cfc041152c1b969089
+DIST cinnamon-desktop-2.6.5.tar.gz 528817 SHA256 a004790f46d1960592f9462cbf6d394d9a5c66b31bb13cc295ed8acb1135924a SHA512 435542d6f5f58373e5bc7b8a613f06ffd4b7c3ec68e368620e66cc1527bceccd63ea5b79a3be3e29cc8ba14e53a6873740fd985c82a5b496141b5eed8297b30c WHIRLPOOL 7f441a120d6839f032eb0bb7fb43e5fafce2f9f1d5715f20ff82180826b5c58fa12401f62d122305ce5b34530406050ecf2335905dc74d8afa618c262764f03a
diff --git a/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.4.2.ebuild b/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.4.2.ebuild
new file mode 100644
index 000000000000..bb0ee9f780f0
--- /dev/null
+++ b/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-any-r1
+
+DESCRIPTION="A collection of libraries and utilites used by Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-desktop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="0/4" # subslot = libcinnamon-desktop soname version
+KEYWORDS="amd64 x86"
+IUSE="+introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gdk-pixbuf-2.21.3:2[introspection?]
+ >=x11-libs/gtk+-3.3.6:3[introspection?]
+ >=x11-libs/libXext-1.1
+ >=x11-libs/libXrandr-1.3
+ x11-libs/cairo:=[X]
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=gnome-base/gsettings-desktop-schemas-3.5.91
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.6
+ gnome-base/gnome-common
+ x11-proto/randrproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+
+ # Fix intltool unittest
+ echo "schemas/org.cinnamon.desktop.keybindings.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.keybindings.media-keys.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.notifications.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.privacy.gschema.xml.in.in" >> po/POTFILES.in
+
+ python_fix_shebang files
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS README"
+
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
diff --git a/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.4.ebuild b/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.4.ebuild
new file mode 100644
index 000000000000..318e399b4363
--- /dev/null
+++ b/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-single-r1
+
+DESCRIPTION="A collection of libraries and utilites used by Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-desktop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="0/4" # subslot = libcinnamon-desktop soname version
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection systemd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=x11-libs/gdk-pixbuf-2.22:2[introspection?]
+ >=x11-libs/gtk+-3.3.16:3[introspection?]
+ >=x11-libs/libXext-1.1
+ >=x11-libs/libXrandr-1.3
+ x11-libs/cairo:=[X]
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=gnome-base/gsettings-desktop-schemas-3.5.91
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7 )
+
+ ${PYTHON_DEPS}
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.6
+ gnome-base/gnome-common
+ x11-proto/randrproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+
+ # Fix intltool unittest
+ echo "schemas/org.cinnamon.desktop.keybindings.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.keybindings.media-keys.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.notifications.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.privacy.gschema.xml.in.in" >> po/POTFILES.in
+
+ python_fix_shebang files
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS README"
+
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # set sane default gschema values for systemd users
+ if use systemd; then
+ insinto /usr/share/glib-2.0/schemas/
+ newins "${FILESDIR}"/${PN}-2.6.4.systemd.gschema.override ${PN}.systemd.gschema.override
+ fi
+}
diff --git a/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.5.ebuild b/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.5.ebuild
new file mode 100644
index 000000000000..babfe557f86e
--- /dev/null
+++ b/gnome-extra/cinnamon-desktop/cinnamon-desktop-2.6.5.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-single-r1
+
+DESCRIPTION="A collection of libraries and utilites used by Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-desktop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ FDL-1.1+ LGPL-2+"
+SLOT="0/4" # subslot = libcinnamon-desktop soname version
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection systemd"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=x11-libs/gdk-pixbuf-2.22:2[introspection?]
+ >=x11-libs/gtk+-3.3.16:3[introspection?]
+ >=x11-libs/libXext-1.1
+ >=x11-libs/libXrandr-1.3
+ x11-libs/cairo:=[X]
+ x11-libs/libX11
+ x11-libs/libxkbfile
+ x11-misc/xkeyboard-config
+ >=gnome-base/gsettings-desktop-schemas-3.5.91
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+
+ ${PYTHON_DEPS}
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.6
+ gnome-base/gnome-common
+ x11-proto/randrproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ python_setup
+}
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+
+ # Fix intltool unittest
+ echo "schemas/org.cinnamon.desktop.keybindings.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.keybindings.media-keys.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.notifications.gschema.xml.in.in" >> po/POTFILES.in
+ echo "schemas/org.cinnamon.desktop.privacy.gschema.xml.in.in" >> po/POTFILES.in
+
+ python_fix_shebang files
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS README"
+
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
+
+src_install() {
+ gnome2_src_install
+
+ # set sane default gschema values for systemd users
+ if use systemd; then
+ insinto /usr/share/glib-2.0/schemas/
+ newins "${FILESDIR}"/${PN}-2.6.4.systemd.gschema.override ${PN}.systemd.gschema.override
+ fi
+}
diff --git a/gnome-extra/cinnamon-desktop/files/cinnamon-desktop-2.6.4.systemd.gschema.override b/gnome-extra/cinnamon-desktop/files/cinnamon-desktop-2.6.4.systemd.gschema.override
new file mode 100644
index 000000000000..cf08f9ca2d2b
--- /dev/null
+++ b/gnome-extra/cinnamon-desktop/files/cinnamon-desktop-2.6.4.systemd.gschema.override
@@ -0,0 +1,5 @@
+[org.cinnamon.desktop.session]
+
+screensaver-uses-logind=true
+session-manager-uses-logind=true
+settings-daemon-uses-logind=true
diff --git a/gnome-extra/cinnamon-desktop/metadata.xml b/gnome-extra/cinnamon-desktop/metadata.xml
new file mode 100644
index 000000000000..8cda79ca296c
--- /dev/null
+++ b/gnome-extra/cinnamon-desktop/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <upstream>
+ <remote-id type="github">linuxmint/cinnamon-desktop</remote-id>
+ </upstream>
+</pkgmetadata>