summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-11-25 12:37:41 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-11-25 12:39:42 -0500
commit4fe59e92e50c3ca9486471d87b63acd6b9650eb7 (patch)
treea14f01cf5cff001b51968e17b1b706bb053788ff /games-util/ucon64/ucon64-2.2.2.ebuild
parentnet-analyzer/nagios-check_linux_bonding: update EAPI 5 -> 8 (diff)
downloadgentoo-4fe59e92e50c3ca9486471d87b63acd6b9650eb7.tar.gz
gentoo-4fe59e92e50c3ca9486471d87b63acd6b9650eb7.tar.bz2
gentoo-4fe59e92e50c3ca9486471d87b63acd6b9650eb7.zip
games-util/ucon64: add 2.2.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-util/ucon64/ucon64-2.2.2.ebuild')
-rw-r--r--games-util/ucon64/ucon64-2.2.2.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/games-util/ucon64/ucon64-2.2.2.ebuild b/games-util/ucon64/ucon64-2.2.2.ebuild
new file mode 100644
index 000000000000..617f85487c0d
--- /dev/null
+++ b/games-util/ucon64/ucon64-2.2.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
+HOMEPAGE="http://ucon64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
+S="${WORKDIR}/${P}-src/src"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug usb zlib"
+
+RDEPEND="
+ usb? ( virtual/libusb:0 )
+ zlib? ( sys-libs/zlib:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-respect-flags.patch
+)
+
+src_prepare() {
+ default
+
+ sed "/discmage.so/s|.* \"|\"${EPREFIX}/usr/$(get_libdir)/${PN}/|" \
+ -i ucon64_misc.c || die
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable debug)
+ $(use_with usb libusb)
+ $(use_with zlib)
+ --enable-ppdev
+ --with-libcd64
+ --with-libdiscmage
+ )
+ econf "${econfargs[@]}"
+
+ tc-export AR CC LD
+}
+
+src_install() {
+ dobin ucon64
+
+ exeinto /usr/$(get_libdir)/${PN}
+ doexe libdiscmage/discmage.so
+
+ docinto html
+ dodoc -r ../images ../{changes,developers,faq,hardware,readme}.html
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "Be sure to check ~/.ucon64rc for some options after"
+ elog "you've run uCON64 for the first time."
+ fi
+}