summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/grfcodec
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/grfcodec')
-rw-r--r--games-util/grfcodec/Manifest1
-rw-r--r--games-util/grfcodec/grfcodec-6.0.4.ebuild50
-rw-r--r--games-util/grfcodec/metadata.xml5
3 files changed, 56 insertions, 0 deletions
diff --git a/games-util/grfcodec/Manifest b/games-util/grfcodec/Manifest
new file mode 100644
index 000000000000..0f672607b824
--- /dev/null
+++ b/games-util/grfcodec/Manifest
@@ -0,0 +1 @@
+DIST grfcodec-6.0.4-source.tar.xz 165756 SHA256 7ec1f903cc48b73be9192a23f3fa14dc2a024d8edc4d2dfafa245e700e650cdb SHA512 cfbbd1cfae7f2d2ba08ca32d8af68f6885c15dddb6ab941bed32d6c15bf9581e0b4ba19a16a5e48e6d6e070438732df232d3f3f008d42baad77a93f931ad0331 WHIRLPOOL 6cbd33a2aa503c858b1b5eeabd8d201e54d68ea618369b464de05f262236303e4f5960119ba86ed792c076c354ce757c804f01a6e1f90d552be276f26004028d
diff --git a/games-util/grfcodec/grfcodec-6.0.4.ebuild b/games-util/grfcodec/grfcodec-6.0.4.ebuild
new file mode 100644
index 000000000000..894722305b24
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-6.0.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [ "${PV%9999}" != "${PV}" ] ; then
+ SCM=mercurial
+ EHG_REPO_URI="http://hg.openttdcoop.org/${PN}"
+fi
+
+inherit toolchain-funcs ${SCM}
+
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="http://dev.openttdcoop.org/projects/grfcodec"
+[[ -z ${SCM} ]] && SRC_URI="http://binaries.openttd.org/extra/${PN}/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE=""
+
+[[ -n ${SCM} ]] && S=${WORKDIR}/${PN}
+
+DEPEND="!games-util/nforenum
+ dev-lang/perl
+ dev-libs/boost
+ media-libs/libpng:0"
+RDEPEND=""
+
+src_prepare() {
+# Set up Makefile.local so that we respect CXXFLAGS/LDFLAGS
+cat > Makefile.local <<-__EOF__
+ CXX=$(tc-getCXX)
+ BOOST_INCLUDE=/usr/include
+ CXXFLAGS=${CXXFLAGS}
+ LDOPT=${LDFLAGS}
+ UPX=
+ V=1
+ FLAGS=
+ EXE=
+ __EOF__
+ sed -i -e 's/-O2//g' Makefile || die
+}
+
+src_install() {
+ dobin grfcodec grfid grfstrip nforenum
+ doman docs/*.1
+ dodoc changelog.txt docs/*.txt
+}
diff --git a/games-util/grfcodec/metadata.xml b/games-util/grfcodec/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-util/grfcodec/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>