summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2021-07-19 21:27:15 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-08-08 16:45:53 -0400
commitc18919d8279f0e28c4791d03ad2143abc9aff3e1 (patch)
treea478ccf9ea571e720dfe79baf7d521d3ffebb427 /games-strategy
parentwww-client/seamonkey: Moved rust patch to my dev space (diff)
downloadgentoo-c18919d8279f0e28c4791d03ad2143abc9aff3e1.tar.gz
gentoo-c18919d8279f0e28c4791d03ad2143abc9aff3e1.tar.bz2
gentoo-c18919d8279f0e28c4791d03ad2143abc9aff3e1.zip
games-strategy/augustus: new ebuild
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/18772 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/augustus/Manifest1
-rw-r--r--games-strategy/augustus/augustus-3.0.1.ebuild51
-rw-r--r--games-strategy/augustus/files/README.gentoo7
-rw-r--r--games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch11
-rw-r--r--games-strategy/augustus/files/augustus-3.0.1-uncapped.patch16
-rw-r--r--games-strategy/augustus/metadata.xml24
6 files changed, 110 insertions, 0 deletions
diff --git a/games-strategy/augustus/Manifest b/games-strategy/augustus/Manifest
new file mode 100644
index 000000000000..d495e4cf7676
--- /dev/null
+++ b/games-strategy/augustus/Manifest
@@ -0,0 +1 @@
+DIST augustus-3.0.1.tar.gz 47539500 BLAKE2B 43e808959f176e4024866074c227814e2be75175cbbca60fbc430a7617941766b8a00ae6f56c08239c5ed8cd60d637109e963eba859c78d60f7b37d54079e7c4 SHA512 4929763a4436863525c4d3f93570090ce066ea2abfe56766d991b7ebc03b34fc53fc8c6dcbb7f5c96e2e10d233bb5966581d148db7d7ea2eac5c1435cc4327bd
diff --git a/games-strategy/augustus/augustus-3.0.1.ebuild b/games-strategy/augustus/augustus-3.0.1.ebuild
new file mode 100644
index 000000000000..9714036d3284
--- /dev/null
+++ b/games-strategy/augustus/augustus-3.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg cmake readme.gentoo-r1
+
+DESCRIPTION="Feature-enhanced open source re-implementation of Caesar III"
+HOMEPAGE="https://github.com/Keriew/augustus"
+SRC_URI="https://github.com/Keriew/augustus/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="uncapped"
+
+DEPEND="
+ dev-libs/expat
+ media-libs/libpng:0=
+ media-libs/libsdl2[joystick,video,sound]
+ media-libs/sdl2-mixer
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.0.1-desktop_rename.patch"
+)
+
+src_prepare() {
+ use uncapped && eapply "${FILESDIR}"/${PN}-3.0.1-uncapped.patch
+ cmake_src_prepare
+}
+
+src_install() {
+ cmake_src_install
+ dodir /usr/libexec
+ mv "${ED}/usr/bin/augustus" "${ED}/usr/libexec/augustus-game" ||
+ die "Failed to rename executable (required to set default resources location)."
+ newbin - augustus-game <<-EOF
+ #!/usr/bin/env sh
+ exec "${EPREFIX}/usr/libexec/augustus-game" "\${1:-\${HOME}/.local/share/julius/app}"
+ EOF
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/games-strategy/augustus/files/README.gentoo b/games-strategy/augustus/files/README.gentoo
new file mode 100644
index 000000000000..f6e9503cd582
--- /dev/null
+++ b/games-strategy/augustus/files/README.gentoo
@@ -0,0 +1,7 @@
+Augustus requires you to download the original Caesar 3 resources.
+
+You need to obtain these files from a vendor of the proprietary software.
+You will then need to copy the 'app' directory into '~/.local/share/julius/app'.
+One way to obtain this directory is to download the GOG Caesar 3 edition.
+You can then produce this directory by installing app-arch/innoextract and running:
+ innoextract -m setup_caesar3_2.0.0.9.exe
diff --git a/games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch b/games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch
new file mode 100644
index 000000000000..662940485795
--- /dev/null
+++ b/games-strategy/augustus/files/augustus-3.0.1-desktop_rename.patch
@@ -0,0 +1,11 @@
+--- a/res/augustus.desktop
++++ b/res/augustus.desktop
+@@ -2,7 +2,7 @@
+ [Desktop Entry]
+ Type=Application
+ Version=1.0
+-Exec=augustus
++Exec=augustus-game
+ Icon=com.github.keriew.augustus
+ Name=Augustus
+ GenericName=Roman city management game
diff --git a/games-strategy/augustus/files/augustus-3.0.1-uncapped.patch b/games-strategy/augustus/files/augustus-3.0.1-uncapped.patch
new file mode 100644
index 000000000000..6bd4f93c1a14
--- /dev/null
+++ b/games-strategy/augustus/files/augustus-3.0.1-uncapped.patch
@@ -0,0 +1,16 @@
+From 1d3a24d74bbea85198c2c5d739a16dcc139af18b Mon Sep 17 00:00:00 2001
+From: Horea Christian <chr@chymera.eu>
+Date: Sat, 26 Dec 2020 12:59:15 -0500
+Subject: [PATCH] Unlimited number of Grand Temples.
+
+--- a/src/building/monument.h
++++ b/src/building/monument.h
+@@ -6,7 +6,7 @@
+
+ #define MONUMENT_FINISHED -1
+ #define MONUMENT_START 1
+-#define MAX_GRAND_TEMPLES_PER_CITY 2
++#define MAX_GRAND_TEMPLES_PER_CITY 99
+ #define MARS_OFFERING_FREQUENCY 16
+
+ typedef enum {
diff --git a/games-strategy/augustus/metadata.xml b/games-strategy/augustus/metadata.xml
new file mode 100644
index 000000000000..7318e09e26fe
--- /dev/null
+++ b/games-strategy/augustus/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gentoo@chymera.eu</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ The aim of this project is to provide enhanced, customizable gameplay
+ to Caesar 3 using project Julius UI enhancements. Augustus is able to
+ load Caesar 3 and Julius saves, however saves made with Augustus will
+ not work outside Augustus.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Keriew/augustus</remote-id>
+ </upstream>
+ <use>
+ <flag name="uncapped">Uncap grand temple count</flag>
+ </use>
+</pkgmetadata>