summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-11 17:41:14 +0000
committerSam James <sam@gentoo.org>2021-05-11 17:41:25 +0000
commit314021bd92f94f189fb7d8e7f39d236f701ff0e6 (patch)
tree1cf1ae824e6bc25f8380185895fa8f91107f1145 /games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
parentsci-visualization/dash-table: add dash-table (diff)
downloadgentoo-314021bd92f94f189fb7d8e7f39d236f701ff0e6.tar.gz
gentoo-314021bd92f94f189fb7d8e7f39d236f701ff0e6.tar.bz2
gentoo-314021bd92f94f189fb7d8e7f39d236f701ff0e6.zip
games-strategy/s25rttr: fix GCC 11 build
Closes: https://bugs.gentoo.org/787299 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild')
-rw-r--r--games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild b/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
index 001f1128ae10..dc54ef2deafe 100644
--- a/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.9.0_pre20200723-r100.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -59,6 +59,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0_pre20200723-cmake_lua_version.patch
+ "${FILESDIR}"/${P}-gcc11-include.patch
)
S="${WORKDIR}/s25client-${COMMIT}"
@@ -102,6 +103,9 @@ src_configure() {
-DLUA_VERSION=$(lua_get_version)
)
+ # bug #787299
+ append-cxxflags -std=gnu++14
+
if use test && tc-is-gcc; then
# Work around libasan and libsandbox both wanting to be first.
append-ldflags -static-libasan