summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-01 23:24:42 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-01 23:27:06 +0100
commit727ef34a6076430ed3b1b74586f5474f40b55324 (patch)
tree2c70a360f65cfdeccee9357a401c1f6be8896c65 /games-strategy/hedgewars/files
parentgnome-extra/gnome-shell-extension-control-blur-effect-on-lock-screen: Bump (diff)
downloadgentoo-727ef34a6076430ed3b1b74586f5474f40b55324.tar.gz
gentoo-727ef34a6076430ed3b1b74586f5474f40b55324.tar.bz2
gentoo-727ef34a6076430ed3b1b74586f5474f40b55324.zip
games-strategy/hedgewars: migrate to lua-single.eclass
Locked to 5.1 but by using a bundled version of FindLua.cmake which only considers that version rather than looking for the package "Lua51". Therefore, I have already put machinery in place which requests a specific Lua version. BTW. All tests of both this ebuild and its unmigrated counterpart fail with "unsupported image format" unless media-libs/sdl2-image has been built in USE=png. Haven't checked what happens at run time. Closes: https://bugs.gentoo.org/752714 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-strategy/hedgewars/files')
-rw-r--r--games-strategy/hedgewars/files/hedgewars-1.0.0-cmake_lua_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/games-strategy/hedgewars/files/hedgewars-1.0.0-cmake_lua_version.patch b/games-strategy/hedgewars/files/hedgewars-1.0.0-cmake_lua_version.patch
new file mode 100644
index 000000000000..b1daa2551124
--- /dev/null
+++ b/games-strategy/hedgewars/files/hedgewars-1.0.0-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -202,7 +202,7 @@
+ #lua discovery
+ if(LUA_SYSTEM)
+ if(NOT LUA_LIBRARY OR NOT LUA_INCLUDE_DIR)
+- find_package(Lua)
++ find_package(Lua ${LUA_VERSION} EXACT REQUIRED)
+ endif()
+
+ if(LUA_LIBRARY AND LUA_INCLUDE_DIR)