summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-rpg/daimonin-client
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-rpg/daimonin-client')
-rw-r--r--games-rpg/daimonin-client/Manifest2
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild66
-rw-r--r--games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch28
-rw-r--r--games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch40
-rw-r--r--games-rpg/daimonin-client/metadata.xml11
5 files changed, 147 insertions, 0 deletions
diff --git a/games-rpg/daimonin-client/Manifest b/games-rpg/daimonin-client/Manifest
new file mode 100644
index 000000000000..2c32333321b9
--- /dev/null
+++ b/games-rpg/daimonin-client/Manifest
@@ -0,0 +1,2 @@
+DIST daimonin-client-0.10.5.tar.gz 15554328 SHA256 07bc94207dc77e0cae2bc949fd9df92da853f70343927d39f31e439d2d7ea3c9 SHA512 7f961105f368d7b4279c03e90028581a0efe998311f334f87d4ca6ff22df1a62f9b5911adf20822a282d7ed3796d8cb0643ab458cc51fb46cf3b90815164ac04 WHIRLPOOL e5141b02cb581f391609031b18626cd37eb2ed69dcfc7dc2e53d7b019747a5e63bf9f2cbcb7751b936c8c9e7f1637fe92151ac0370fb6dab3511fca0e8ea2dc4
+DIST daimonin-client-AllMusic-20100827.zip 86844919 SHA256 0732fde7f39b34057d72ab65b00ddefc1c84fcf8ef8fdf00d72fb67f2144d867 SHA512 50ec9524bd934a715271ddef1ea2cec855e93607e5befd1b18b74493400c9e1b2e6e5d829f3b21088b28c67635c0d1479eec53e1626c680f1d34081292607c9f WHIRLPOOL 91d485e1b816c6ee06cca9c18185b2a58f1da1f4231139dbb183a14a2ce3a12bab1891a9506bfe7ee2d9ff91d63801b160a4b67a52be8d2f2c4615d2568edd93
diff --git a/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild b/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
new file mode 100644
index 000000000000..6b71aae8bc04
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.10.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools games
+
+MY_P=${PN}-${PV}
+DESCRIPTION="a graphical 2D tile-based MMORPG"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="http://daimonin.svn.sourceforge.net/viewvc/daimonin/main/client/?view=tar&pathrev=6021
+ -> daimonin-client-0.10.5.tar.gz
+ music? ( mirror://sourceforge/daimonin/Addon%20packs/Music/AllMusic.zip
+ -> daimonin-client-AllMusic-20100827.zip )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="music debug"
+
+RDEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[vorbis]
+ media-libs/sdl-image[png]
+ dev-games/physfs
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ music? ( app-arch/unzip )"
+
+S=${WORKDIR}/client/make/linux
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+ if use music ; then
+ cd client/media
+ rm -f *
+ unpack ${PN}-AllMusic-20100827.zip
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nozlib.patch
+ rm ../../src/include/z{lib,conf}.h
+ sed -i \
+ -e 's:$(d_datadir):$(DESTDIR)$(d_datadir):' \
+ -e '/PROGRAMS/s:daimonin-updater::' \
+ Makefile.am \
+ || die "sed failed"
+ eautoreconf
+ cd ../../src
+ epatch "${FILESDIR}"/${P}-datadir.patch
+}
+
+src_configure() {
+ egamesconf \
+ --disable-simplelayout \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ cd ../..
+ dodoc README*
+ newicon bitmaps/pentagram.png ${PN}.png
+ make_desktop_entry daimonin Daimonin
+ prepgamesdirs
+}
diff --git a/games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch
new file mode 100644
index 000000000000..ea79f7595910
--- /dev/null
+++ b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-datadir.patch
@@ -0,0 +1,28 @@
+--- main.c.old 2010-08-24 19:32:55.000000000 +0200
++++ main.c 2010-09-19 18:49:54.000000000 +0200
+@@ -2386,7 +2386,7 @@
+
+ /* Add the base dir to the search path. The base dir is where all the
+ * defaults are (or should be). */
+- if (!PHYSFS_addToSearchPath(PHYSFS_getBaseDir(), 1))
++ if (!PHYSFS_addToSearchPath(SYSPATH, 1))
+ {
+ LOG(LOG_MSG, "%s\n", PHYSFS_getLastError());
+ }
+@@ -2545,13 +2545,13 @@
+
+ /* Prepend the user dir to the search path. This means files are read from
+ * this location in preference to the defaults. */
+- if (strcmp(PHYSFS_getBaseDir(), home))
+- {
++ /*if (strcmp(PHYSFS_getBaseDir(), home))
++ {*/
+ if (!PHYSFS_addToSearchPath(home, 0))
+ {
+ LOG(LOG_ERROR, "%s\n", PHYSFS_getLastError());
+ }
+- }
++ //}
+
+ /* Prepend any add-on packs to the search path. This means files are read
+ * from these locations in preference to the defaults and the user dir. */
diff --git a/games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch
new file mode 100644
index 000000000000..c342cc3c3850
--- /dev/null
+++ b/games-rpg/daimonin-client/files/daimonin-client-0.10.5-nozlib.patch
@@ -0,0 +1,40 @@
+--- Makefile.am.old 2010-12-01 14:39:11.605648458 -0500
++++ Makefile.am 2010-12-01 14:41:59.875915880 -0500
+@@ -2,23 +2,18 @@
+ daimonin_PROGRAMS = daimonin daimonin-updater
+
+ daimonin_SOURCES = \
+- ../../src/adler32.c \
+ ../../src/anim.c \
+ ../../src/book.c \
+ ../../src/buddy.c \
+ ../../src/chatfilter.c \
+ ../../src/client.c \
+ ../../src/commands.c \
+- ../../src/crc32.c \
+ ../../src/dialog.c \
+ ../../src/event.c \
+ ../../src/filewrap.c \
+ ../../src/font.c \
+ ../../src/group.c \
+ ../../src/ignore.c \
+- ../../src/inffast.c \
+- ../../src/inflate.c \
+- ../../src/inftrees.c \
+ ../../src/interface.c \
+ ../../src/inventory.c \
+ ../../src/item.c \
+@@ -35,11 +30,9 @@
+ ../../src/sprite.c \
+ ../../src/textwin.c \
+ ../../src/tile_stretcher.c \
+- ../../src/uncompr.c \
+ ../../src/wrapper.c \
+- ../../src/widget.c \
+- ../../src/zutil.c
+-daimonin_LDADD = -lSDL_mixer -lSDL_image @SDL_LIBS@ @EXTRA_LIBS@ @PHYSFS_LIBS@
++ ../../src/widget.c
++daimonin_LDADD = -lSDL_mixer -lSDL_image @SDL_LIBS@ @EXTRA_LIBS@ @PHYSFS_LIBS@ -lz
+ daimonin_OBJDIR = objs
+
+ daimonin_updater_SOURCES = \
diff --git a/games-rpg/daimonin-client/metadata.xml b/games-rpg/daimonin-client/metadata.xml
new file mode 100644
index 000000000000..576ef5e3dea4
--- /dev/null
+++ b/games-rpg/daimonin-client/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="music">Install extra music</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">daimonin</remote-id>
+ </upstream>
+</pkgmetadata>