summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-engines/qtads
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-engines/qtads')
-rw-r--r--games-engines/qtads/Manifest1
-rw-r--r--games-engines/qtads/metadata.xml8
-rw-r--r--games-engines/qtads/qtads-2.1.6.ebuild57
3 files changed, 66 insertions, 0 deletions
diff --git a/games-engines/qtads/Manifest b/games-engines/qtads/Manifest
new file mode 100644
index 000000000000..fb2335ff51a3
--- /dev/null
+++ b/games-engines/qtads/Manifest
@@ -0,0 +1 @@
+DIST qtads-2.1.6.tar.bz2 2523761 SHA256 33f29b4c1b225f1a1e7ad1405a1bb7eb8ec4b1d567eac48a120071f7793373c8 SHA512 bd61f6531e2af3484bca06952c174feb2e1157f3f6f8b77e292c724cabb11f31cc413afe4dfb566a216d64702df033033d0667bd4dcb64478b3cd0cf3142dd3e WHIRLPOOL 90814bedfae9b07ff9eb02f070253970aba512c6f1736939c17ba1206e8043c60d5b07f65f94014f191696d339f522762ad3a8e866e624b796c4380b9abfd03a
diff --git a/games-engines/qtads/metadata.xml b/games-engines/qtads/metadata.xml
new file mode 100644
index 000000000000..eef6bd6fadd6
--- /dev/null
+++ b/games-engines/qtads/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">qtads</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-engines/qtads/qtads-2.1.6.ebuild b/games-engines/qtads/qtads-2.1.6.ebuild
new file mode 100644
index 000000000000..002eb2b06aa8
--- /dev/null
+++ b/games-engines/qtads/qtads-2.1.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils fdo-mime qt4-r2 games
+
+DESCRIPTION="Multimedia interpreter for TADS text adventures"
+HOMEPAGE="http://qtads.sourceforge.net"
+SRC_URI="mirror://sourceforge/qtads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound]
+ media-libs/sdl-mixer[midi,vorbis]
+ media-libs/sdl-sound[mp3]
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ eqmake4 qtads.pro -after CONFIG-=silent
+}
+
+src_install() {
+ dogamesbin qtads
+ doman qtads.6
+ dodoc AUTHORS HTML_TADS_LICENSE NEWS README
+ newicon -s 256 qtads_256x256.png ${PN}.png
+ insinto /usr/share/icons
+ doins -r icons/hicolor
+ insinto /usr/share/mime/packages
+ doins icons/qtads.xml
+ make_desktop_entry qtads QTads qtads Game "GenericName=TADS Multimedia Interpreter\nMimeType=application/x-tads;application/x-t3vm-image;"
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}