summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-31 01:56:45 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-31 02:09:28 -0500
commitf6a0fc872fbd0e619b21e8f557f8e276f30cc1f2 (patch)
tree16ce6303dff8cbb7ffcf4c1383cef304f41ee2b1 /games-emulation/pcsx2
parentmedia-libs/ampache_browser: Stabilize 1.0.6 x86, #921092 (diff)
downloadgentoo-f6a0fc872fbd0e619b21e8f557f8e276f30cc1f2.tar.gz
gentoo-f6a0fc872fbd0e619b21e8f557f8e276f30cc1f2.tar.bz2
gentoo-f6a0fc872fbd0e619b21e8f557f8e276f30cc1f2.zip
games-emulation/pcsx2: update live
Upstream has discovered that unbundling some dependencies reduces build time. ARCH_FLAG was removed, it was useful to pass the actual minimal -m* flags, but -DDISABLE_ADVANCE_SIMD comes close enough and prevents passing the more problematic -march=native. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 7dcbf7dc75d7..43536202eed1 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -29,13 +29,16 @@ RESTRICT="!test? ( test )"
# dlopen: qtsvg, vulkan-loader, wayland
COMMON_DEPEND="
+ app-arch/lz4:=
app-arch/xz-utils
+ app-arch/zstd:=
dev-libs/libaio
>=dev-qt/qtbase-6.6.0:6[gui,widgets]
>=dev-qt/qtsvg-6.6.0:6
media-libs/libglvnd
media-libs/libpng:=
>=media-libs/libsdl2-2.28.5[haptic,joystick]
+ media-libs/libwebp:=
media-video/ffmpeg:=
net-libs/libpcap
net-misc/curl
@@ -94,6 +97,7 @@ src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=no
+ -DDISABLE_ADVANCE_SIMD=yes
-DDISABLE_BUILD_DATE=yes
-DENABLE_TESTS=$(usex test)
-DUSE_LINKED_FFMPEG=yes
@@ -102,11 +106,6 @@ src_configure() {
-DWAYLAND_API=$(usex wayland)
-DX11_API=yes # X libs are currently hard-required either way
- # sse4.1 is the bare minimum required, -m is required at build time
- # (see PCSX2Base.h) and it dies if no support at runtime (AppInit.cpp)
- # https://github.com/PCSX2/pcsx2/pull/4329
- -DARCH_FLAG=-msse4.1
-
# not packaged due to bug #885471, but still disable for no automagic
-DCMAKE_DISABLE_FIND_PACKAGE_Libbacktrace=yes