summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-15 00:59:44 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-15 02:26:52 -0500
commit45313b7cf62271ff0d7e65b7853c0aafbc18b93e (patch)
tree014ea68dde056a221ba9fe24516aed237d0a8212 /games-emulation/pcsx2
parentgames-emulation/pcsx2: force-remove lower bounds on Qt6 and SDL2 (diff)
downloadgentoo-45313b7cf62271ff0d7e65b7853c0aafbc18b93e.tar.gz
gentoo-45313b7cf62271ff0d7e65b7853c0aafbc18b93e.tar.bz2
gentoo-45313b7cf62271ff0d7e65b7853c0aafbc18b93e.zip
games-emulation/pcsx2: update live, require clang
Likely an easy fix that could be done from our end, but no longer have the patience to support things that upstream is refusing to support. Albeit may drop the requirement if it gets fixed by the time of next bump, but otherwise it'll likely stick around. Likely not worth using the llvm eclass here, not linking with and only need to pick the current compiler. fwiw forcing clang removes the need for the lto patch. Also BUILD_DATE option was removed. GIT_TAG bits may also need updates but will check that next time do a bump as it does not matter in live. LICENSE may need a bit of reviewing too given upstream added a compilation of all the licenses used. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index 178e5a77996c..586432db9b7e 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake desktop fcaps flag-o-matic
+inherit cmake desktop fcaps flag-o-matic toolchain-funcs
if [[ ${PV} == 9999 ]]; then
inherit git-r3
@@ -65,6 +65,7 @@ DEPEND="
"
BDEPEND="
dev-qt/qttools:6[linguist]
+ sys-devel/clang:*
wayland? (
dev-util/wayland-scanner
kde-frameworks/extra-cmake-modules
@@ -72,7 +73,6 @@ BDEPEND="
"
PATCHES=(
- "${FILESDIR}"/${PN}-1.7.3773-lto.patch
"${FILESDIR}"/${PN}-1.7.4667-flags.patch
"${FILESDIR}"/${PN}-1.7.5232-cubeb-automagic.patch
)
@@ -93,6 +93,13 @@ src_prepare() {
}
src_configure() {
+ # upstream only supports clang and ignores gcc issues, e.g.
+ # https://github.com/PCSX2/pcsx2/issues/10624#issuecomment-1890326047
+ if ! tc-is-clang; then
+ local -x CC=${CHOST}-clang CXX=${CHOST}-clang++
+ strip-unsupported-flags
+ fi
+
if use vulkan; then
# for bundled glslang (bug #858374)
append-flags -fno-strict-aliasing
@@ -104,7 +111,6 @@ src_configure() {
local mycmakeargs=(
-DBUILD_SHARED_LIBS=no
-DDISABLE_ADVANCE_SIMD=yes
- -DDISABLE_BUILD_DATE=yes
-DENABLE_TESTS=$(usex test)
-DUSE_LINKED_FFMPEG=yes
-DUSE_VTUNE=no