summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-14 00:10:13 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-14 00:15:00 +0100
commit04620f343c1a03f54685b0848b59f2f2d2b3ffbb (patch)
treeb42d8d912e298dd460190f6eb1817bb71ebce8d8 /games-emulation/dolphin/dolphin-9999.ebuild
parentdev-libs/glib: remove unused file (diff)
downloadgentoo-04620f343c1a03f54685b0848b59f2f2d2b3ffbb.tar.gz
gentoo-04620f343c1a03f54685b0848b59f2f2d2b3ffbb.tar.bz2
gentoo-04620f343c1a03f54685b0848b59f2f2d2b3ffbb.zip
games-emulation/dolphin: [QA] Sync live ebuild
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'games-emulation/dolphin/dolphin-9999.ebuild')
-rw-r--r--games-emulation/dolphin/dolphin-9999.ebuild69
1 files changed, 24 insertions, 45 deletions
diff --git a/games-emulation/dolphin/dolphin-9999.ebuild b/games-emulation/dolphin/dolphin-9999.ebuild
index b726d122197e..f6dddcb6d01f 100644
--- a/games-emulation/dolphin/dolphin-9999.ebuild
+++ b/games-emulation/dolphin/dolphin-9999.ebuild
@@ -1,19 +1,18 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-PLOCALES="ar ca cs da_DK de el en es fa fr hr hu it ja ko ms_MY nb nl pl pt_BR pt ro_RO ru sr sv tr zh_CN zh_TW"
+PLOCALES="ar ca cs da_DK de el en es fa fr hr hu it ja ko ms_MY nb nl pl pt pt_BR ro_RO ru sr sv tr zh_CN zh_TW"
PLOCALE_BACKUP="en"
WX_GTK_VER="3.0"
-inherit cmake-utils eutils l10n pax-utils toolchain-funcs versionator wxwidgets
+inherit cmake-utils desktop l10n pax-utils toolchain-funcs versionator wxwidgets
-if [[ ${PV} == 9999* ]]
+if [[ ${PV} == *9999 ]]
then
EGIT_REPO_URI="https://github.com/dolphin-emu/dolphin"
inherit git-r3
- KEYWORDS=""
else
SRC_URI="https://github.com/${PN}-emu/${PN}/archive/${PV}.zip -> ${P}.zip"
KEYWORDS="~amd64"
@@ -24,15 +23,15 @@ HOMEPAGE="https://www.dolphin-emu.org/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="alsa ao bluetooth doc egl +evdev ffmpeg llvm log lto openal +pch portaudio profile pulseaudio qt5 sdl upnp +wxwidgets"
+IUSE="alsa ao bluetooth doc egl +evdev ffmpeg libav llvm log lto openal +pch portaudio profile pulseaudio qt5 sdl upnp +wxwidgets"
-RDEPEND=">=media-libs/libsfml-2.1
+RDEPEND="
+ >=media-libs/libsfml-2.1
>net-libs/enet-1.3.7
>=net-libs/mbedtls-2.1.1
dev-libs/lzo
- media-libs/libpng:=
- sys-libs/glibc
- sys-libs/readline:=
+ media-libs/libpng:0=
+ sys-libs/readline:0=
sys-libs/zlib
x11-libs/libXext
x11-libs/libXi
@@ -44,14 +43,17 @@ RDEPEND=">=media-libs/libsfml-2.1
bluetooth? ( net-wireless/bluez )
egl? ( media-libs/mesa[egl] )
evdev? (
- dev-libs/libevdev
- virtual/udev
+ dev-libs/libevdev
+ virtual/udev
+ )
+ ffmpeg? (
+ libav? ( media-video/libav:= )
+ !libav? ( media-video/ffmpeg:= )
)
- ffmpeg? ( virtual/ffmpeg )
llvm? ( sys-devel/llvm )
openal? (
- media-libs/openal
- media-libs/libsoundtouch
+ media-libs/openal
+ media-libs/libsoundtouch
)
portaudio? ( media-libs/portaudio )
profile? ( dev-util/oprofile )
@@ -64,35 +66,18 @@ RDEPEND=">=media-libs/libsfml-2.1
sdl? ( media-libs/libsdl2[haptic,joystick] )
upnp? ( >=net-libs/miniupnpc-1.7 )
wxwidgets? (
- dev-libs/glib:2
- x11-libs/gtk+:2
- x11-libs/wxGTK:${WX_GTK_VER}[opengl,X]
- )
- "
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/wxGTK:${WX_GTK_VER}[opengl,X]
+ )"
DEPEND="${RDEPEND}
- >=dev-util/cmake-2.8.8
- >=sys-devel/gcc-4.9.0
app-arch/zip
media-libs/freetype
sys-devel/gettext
- virtual/pkgconfig
- "
-
-pkg_pretend() {
-
- local ver=4.9.0
- local msg="${PN} needs at least GCC ${ver} set to compile."
-
- if [[ ${MERGE_TYPE} != binary ]]; then
- if ! version_is_at_least ${ver} $(gcc-fullversion); then
- eerror ${msg}
- die ${msg}
- fi
- fi
-
-}
+ virtual/pkgconfig"
src_prepare() {
+ cmake-utils_src_prepare
# Remove automatic dependencies to prevent building without flags enabled.
if use !alsa; then
@@ -146,13 +131,12 @@ src_prepare() {
}
src_configure() {
-
if use wxwidgets; then
need-wxwidgets unicode
fi
local mycmakeargs=(
- "-DUSE_SHARED_ENET=ON"
+ -DUSE_SHARED_ENET=ON
$( cmake-utils_use ffmpeg ENCODE_FRAMEDUMPS )
$( cmake-utils_use log FASTLOG )
$( cmake-utils_use profile OPROFILING )
@@ -169,12 +153,7 @@ src_configure() {
cmake-utils_src_configure
}
-src_compile() {
-
- cmake-utils_src_compile
-}
src_install() {
-
cmake-utils_src_install
dodoc Readme.md