summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-05-02 20:43:33 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-05-02 20:45:35 +0100
commit877fd25f3573d13adb4b60ec8772b24a5dee68e8 (patch)
treef183a66fd6effe51b21034b9d4d21e4a56a46e79 /games-arcade
parentgames-arcade/holotz-castle: use tool-refixed CXX (diff)
downloadgentoo-877fd25f3573d13adb4b60ec8772b24a5dee68e8.tar.gz
gentoo-877fd25f3573d13adb4b60ec8772b24a5dee68e8.tar.bz2
gentoo-877fd25f3573d13adb4b60ec8772b24a5dee68e8.zip
games-arcade/holotz-castle: tweak for gcc-11
Reported-by: Agostino Sarubbo Closes: https://bugs.gentoo.org/739092 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc-11.patch30
-rw-r--r--games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild3
2 files changed, 32 insertions, 1 deletions
diff --git a/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc-11.patch b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc-11.patch
new file mode 100644
index 000000000000..311c352731d8
--- /dev/null
+++ b/games-arcade/holotz-castle/files/holotz-castle-1.3.14-gcc-11.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/739092
+--- a/JLib/JLib/Util/JTextFile.cpp
++++ b/JLib/JLib/Util/JTextFile.cpp
+@@ -145,7 +145,7 @@ bool JTextFile::FindNext(const s8 *str, bool jump)
+
+ tmp = strstr(ptr, str);
+
+- if (tmp > 0)
++ if (tmp)
+ ptr = tmp;
+ else
+ {
+@@ -153,7 +153,7 @@ bool JTextFile::FindNext(const s8 *str, bool jump)
+ {
+ tmp = strstr(buff, str);
+
+- if (tmp > 0)
++ if (tmp)
+ ptr = tmp;
+ else
+ return false;
+@@ -233,7 +233,7 @@ bool JTextFile::ReadQuotedWord(s8 *str)
+ ++ptr;
+ end = ptr;
+
+- if (0 >= (end = strstr(ptr, "\"")))
++ if ((end = strstr(ptr, "\"")) == NULL)
+ {
+ // No hay comillas de cierre
+ ptr = org;
diff --git a/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild b/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
index 202a35dbf6aa..6b5db838ab75 100644
--- a/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
+++ b/games-arcade/holotz-castle/holotz-castle-1.3.14-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit desktop toolchain-funcs
DESCRIPTION="2D platform game"
@@ -29,6 +29,7 @@ PATCHES=(
"${FILESDIR}"/${P}-build.patch
"${FILESDIR}"/${P}-gcc44.patch
"${FILESDIR}"/${P}-underlink.patch
+ "${FILESDIR}"/${P}-gcc-11.patch
)
src_compile() {