summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-03 10:43:00 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-03 10:43:00 -0500
commit3f9d3f4b6d210a77f2ab52be3d448f1e8d6429f0 (patch)
treea92dbe3c6faacaf7789868991f9a21446b2c1e41 /games-action/bzflag/bzflag-2.4.2-r1.ebuild
parentmedia-sound/qmmp: Bump to versions 0.9.3 and 1.0.1 (diff)
downloadgentoo-3f9d3f4b6d210a77f2ab52be3d448f1e8d6429f0.tar.gz
gentoo-3f9d3f4b6d210a77f2ab52be3d448f1e8d6429f0.tar.bz2
gentoo-3f9d3f4b6d210a77f2ab52be3d448f1e8d6429f0.zip
remove upnp support since upstream doesn't support it on linux
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-action/bzflag/bzflag-2.4.2-r1.ebuild')
-rw-r--r--games-action/bzflag/bzflag-2.4.2-r1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/games-action/bzflag/bzflag-2.4.2-r1.ebuild b/games-action/bzflag/bzflag-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..e0273ad68ac6
--- /dev/null
+++ b/games-action/bzflag/bzflag-2.4.2-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils flag-o-matic games
+
+DESCRIPTION="3D tank combat simulator game"
+HOMEPAGE="http://www.bzflag.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="dedicated sdl"
+
+UIDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[sound,joystick,video]
+ media-libs/glew
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXxf86vm"
+
+DEPEND=">=net-misc/curl-7.15.0
+ sys-libs/ncurses
+ net-dns/c-ares
+ sdl? ( ${UIDEPEND} )
+ !sdl? ( !dedicated? ( ${UIDEPEND} ) )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nocxxflags.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ if use dedicated && ! use sdl ; then
+ ewarn
+ ewarn "You are building a server-only copy of BZFlag"
+ ewarn
+ myconf="--disable-client --without-SDL"
+ fi
+ egamesconf \
+ --disable-ccachetest \
+ --without-regex \
+ --disable-UPnP \
+ ${myconf}
+}
+
+src_install() {
+ default
+ dodoc PORTING DEVINFO
+
+ if use sdl || ! use dedicated ; then
+ newicon "data/bzflag-48x48.png" ${PN}.png
+ make_desktop_entry ${PN} "BZFlag"
+ fi
+
+ prune_libtool_files --modules
+ prepgamesdirs
+}