summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-16 16:09:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-17 12:23:01 +0100
commit3f87d0f277763f1cd621a78e34eb226d89020863 (patch)
tree20011860f15dcc64492eb5298bae25cde2aee779 /eclass/distutils-r1.eclass
parentapp-editors/gvim: enable ruby32 (diff)
downloadgentoo-3f87d0f277763f1cd621a78e34eb226d89020863.tar.gz
gentoo-3f87d0f277763f1cd621a78e34eb226d89020863.tar.bz2
gentoo-3f87d0f277763f1cd621a78e34eb226d89020863.zip
distutils-r1.eclass: Call gpep517 via EPYTHON
Call gpep517 via EPYTHON, in order to make it possible to use any plugins that were installed during python_compile() in python_test(). This is used in dev-python/setuptools-gettext that is tested via building an example project relying on the plugin. Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/34312 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 0a9815f2d459..5a99ba88eddb 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1243,7 +1243,7 @@ _distutils-r1_get_backend() {
if [[ -f pyproject.toml ]]; then
# if pyproject.toml exists, try getting the backend from it
# NB: this could fail if pyproject.toml doesn't list one
- build_backend=$(gpep517 get-backend)
+ build_backend=$("${EPYTHON}" -m gpep517 get-backend)
fi
if [[ -z ${build_backend} && ${DISTUTILS_USE_PEP517} == setuptools &&
-f setup.py ]]
@@ -1317,7 +1317,7 @@ distutils_wheel_install() {
einfo " Installing ${wheel##*/} to ${root}"
local cmd=(
- gpep517 install-wheel
+ "${EPYTHON}" -m gpep517 install-wheel
--destdir="${root}"
--interpreter="${PYTHON}"
--prefix="${EPREFIX}/usr"
@@ -1446,7 +1446,7 @@ distutils_pep517_install() {
local build_backend=$(_distutils-r1_get_backend)
einfo " Building the wheel for ${PWD#${WORKDIR}/} via ${build_backend}"
local cmd=(
- gpep517 build-wheel
+ "${EPYTHON}" -m gpep517 build-wheel
--prefix="${EPREFIX}/usr"
--backend "${build_backend}"
--output-fd 3