summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2025-01-11 05:57:16 +0000
committerSam James <sam@gentoo.org>2025-01-11 06:36:35 +0000
commitb5a52e4ff39a8485c504f1d449597b40077bf3e6 (patch)
treeff0ba7de76f1ffcfe0779e9e16c4cbe65e240794 /dev-vcs
parentsys-kernel/gentoo-kernel-bin: Copy sbsigntools deps to 6.6.{70,71} (diff)
downloadgentoo-b5a52e4ff39a8485c504f1d449597b40077bf3e6.tar.gz
gentoo-b5a52e4ff39a8485c504f1d449597b40077bf3e6.tar.bz2
gentoo-b5a52e4ff39a8485c504f1d449597b40077bf3e6.zip
dev-vcs/git: fix USE=mediawiki
The Makefile actually gets the Perl handling right so if we let it install first, we already have something in the correct Perl dir, and our mv fails. Just do it afterwards instead. Closes: https://bugs.gentoo.org/947845 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git/git-2.48.0.ebuild8
-rw-r--r--dev-vcs/git/git-9999-r1.ebuild12
-rw-r--r--dev-vcs/git/git-9999-r2.ebuild12
-rw-r--r--dev-vcs/git/git-9999-r3.ebuild12
4 files changed, 16 insertions, 28 deletions
diff --git a/dev-vcs/git/git-2.48.0.ebuild b/dev-vcs/git/git-2.48.0.ebuild
index c90d0aa8bf6a..8d8904831f08 100644
--- a/dev-vcs/git/git-2.48.0.ebuild
+++ b/dev-vcs/git/git-2.48.0.ebuild
@@ -317,10 +317,6 @@ src_install() {
dodoc git-subtree.txt
popd &>/dev/null || die
- if use mediawiki ; then
- git_emake -C contrib/mw-to-git DESTDIR="${D}" install
- fi
-
# diff-highlight
dobin contrib/diff-highlight/diff-highlight
newdoc contrib/diff-highlight/README README.diff-highlight
@@ -397,6 +393,10 @@ src_install() {
dobin contrib/credential/netrc/git-credential-netrc
fi
+ if use mediawiki ; then
+ git_emake -C contrib/mw-to-git DESTDIR="${D}" install
+ fi
+
if ! use subversion ; then
rm -f "${ED}"/usr/libexec/git-core/git-svn \
"${ED}"/usr/share/man/man1/git-svn.1*
diff --git a/dev-vcs/git/git-9999-r1.ebuild b/dev-vcs/git/git-9999-r1.ebuild
index 41c0ed848010..8d8904831f08 100644
--- a/dev-vcs/git/git-9999-r1.ebuild
+++ b/dev-vcs/git/git-9999-r1.ebuild
@@ -148,10 +148,6 @@ REQUIRED_USE="
RESTRICT="!test? ( test )"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.48.0_rc2-meson-deps.patch
-)
-
pkg_setup() {
if use subversion && has_version "dev-vcs/subversion[dso]" ; then
ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
@@ -321,10 +317,6 @@ src_install() {
dodoc git-subtree.txt
popd &>/dev/null || die
- if use mediawiki ; then
- git_emake -C contrib/mw-to-git DESTDIR="${D}" install
- fi
-
# diff-highlight
dobin contrib/diff-highlight/diff-highlight
newdoc contrib/diff-highlight/README README.diff-highlight
@@ -401,6 +393,10 @@ src_install() {
dobin contrib/credential/netrc/git-credential-netrc
fi
+ if use mediawiki ; then
+ git_emake -C contrib/mw-to-git DESTDIR="${D}" install
+ fi
+
if ! use subversion ; then
rm -f "${ED}"/usr/libexec/git-core/git-svn \
"${ED}"/usr/share/man/man1/git-svn.1*
diff --git a/dev-vcs/git/git-9999-r2.ebuild b/dev-vcs/git/git-9999-r2.ebuild
index 41c0ed848010..8d8904831f08 100644
--- a/dev-vcs/git/git-9999-r2.ebuild
+++ b/dev-vcs/git/git-9999-r2.ebuild
@@ -148,10 +148,6 @@ REQUIRED_USE="
RESTRICT="!test? ( test )"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.48.0_rc2-meson-deps.patch
-)
-
pkg_setup() {
if use subversion && has_version "dev-vcs/subversion[dso]" ; then
ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
@@ -321,10 +317,6 @@ src_install() {
dodoc git-subtree.txt
popd &>/dev/null || die
- if use mediawiki ; then
- git_emake -C contrib/mw-to-git DESTDIR="${D}" install
- fi
-
# diff-highlight
dobin contrib/diff-highlight/diff-highlight
newdoc contrib/diff-highlight/README README.diff-highlight
@@ -401,6 +393,10 @@ src_install() {
dobin contrib/credential/netrc/git-credential-netrc
fi
+ if use mediawiki ; then
+ git_emake -C contrib/mw-to-git DESTDIR="${D}" install
+ fi
+
if ! use subversion ; then
rm -f "${ED}"/usr/libexec/git-core/git-svn \
"${ED}"/usr/share/man/man1/git-svn.1*
diff --git a/dev-vcs/git/git-9999-r3.ebuild b/dev-vcs/git/git-9999-r3.ebuild
index 41c0ed848010..8d8904831f08 100644
--- a/dev-vcs/git/git-9999-r3.ebuild
+++ b/dev-vcs/git/git-9999-r3.ebuild
@@ -148,10 +148,6 @@ REQUIRED_USE="
RESTRICT="!test? ( test )"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.48.0_rc2-meson-deps.patch
-)
-
pkg_setup() {
if use subversion && has_version "dev-vcs/subversion[dso]" ; then
ewarn "Per Gentoo bugs #223747, #238586, when subversion is built"
@@ -321,10 +317,6 @@ src_install() {
dodoc git-subtree.txt
popd &>/dev/null || die
- if use mediawiki ; then
- git_emake -C contrib/mw-to-git DESTDIR="${D}" install
- fi
-
# diff-highlight
dobin contrib/diff-highlight/diff-highlight
newdoc contrib/diff-highlight/README README.diff-highlight
@@ -401,6 +393,10 @@ src_install() {
dobin contrib/credential/netrc/git-credential-netrc
fi
+ if use mediawiki ; then
+ git_emake -C contrib/mw-to-git DESTDIR="${D}" install
+ fi
+
if ! use subversion ; then
rm -f "${ED}"/usr/libexec/git-core/git-svn \
"${ED}"/usr/share/man/man1/git-svn.1*