summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2019-12-10 12:42:12 +0000
committerMarek Szuba <marecki@gentoo.org>2019-12-10 12:49:35 +0000
commitc8a84e1e72cf2c275b62d980e38b370e06561ab9 (patch)
tree5bf9641b58d5a732715fe20d1e0ad1776e88aa30 /dev-util
parentprofiles: unmask dvi2tty (diff)
downloadgentoo-c8a84e1e72cf2c275b62d980e38b370e06561ab9.tar.gz
gentoo-c8a84e1e72cf2c275b62d980e38b370e06561ab9.tar.bz2
gentoo-c8a84e1e72cf2c275b62d980e38b370e06561ab9.zip
dev-util/intel-graphics-compiler: bump to 1.0.2990
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/intel-graphics-compiler/Manifest1
-rw-r--r--dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.2990.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/intel-graphics-compiler/Manifest b/dev-util/intel-graphics-compiler/Manifest
index 172024413196..0966a16acc98 100644
--- a/dev-util/intel-graphics-compiler/Manifest
+++ b/dev-util/intel-graphics-compiler/Manifest
@@ -1,2 +1,3 @@
DIST intel-graphics-compiler-1.0.11.tar.gz 5720630 BLAKE2B 1539de7aec3d0c357159a5be6c446ee4e3c98857fb666ab09ceefdb9ae93b430bc164de2f17848f25aeef1a95ce2066441aa0584354c14ed06fbb9179a17ba58 SHA512 2b4b43b152014329e2d9dcba1a5b832fb8c641a3bd004345ddc8d36a237bc15f112ef007894b5adbe175bf08584093adcee655b5e61a9da81d6956974e03248f
DIST intel-graphics-compiler-1.0.2878.tar.gz 5920418 BLAKE2B 99522118d08183836c6e62f80c98b2cc716dd22d7dc82d05841e87e42f10025508c6254cebe2f886da8454cc4cc4b3a9ee06ce5a3bc04246c88f499f63f8f1ae SHA512 3b6dc9b945fddb3d0bc716f4598c4dacb6431c342b580c90f7e9ff8682bdcbde410a960adbfd9e67601d121adc70d2cf23de01bc99c1d0cb86d14b4db77afde5
+DIST intel-graphics-compiler-1.0.2990.tar.gz 5930890 BLAKE2B 038761e74dde52de53eed511a74a39d9b4c69a510ef289d2941b859aea018d6776b5179d2be006b12d3245ffe43a06bfacd9d03ee2d227c2ba2ea39805bf40d2 SHA512 65287348e98f09096418afa02262ad6ce07dd918aa040ac1fb49f7176545c0a6449e68c5e74a11c41641d90495edc7be8e24b32e68d798df906ea3b16e675827
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.2990.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.2990.ebuild
new file mode 100644
index 000000000000..03d09a9af2dd
--- /dev/null
+++ b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.2990.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON="sys-devel/llvm:8=[${MULTILIB_USEDEP}]
+ >=dev-libs/opencl-clang-8.0.1:8=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+LLVM_MAX_SLOT=8
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.9-no_Werror.patch
+)
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix ${LLVM_MAX_SLOT})/$(get_libdir)
+ -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+ -DIGC_PREFERRED_LLVM_VERSION=8
+ )
+ cmake-utils_src_configure
+}