summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-02-15 21:49:55 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2024-02-15 21:50:19 +0100
commit50e5705ceb615fddd35e4ea300fe3418bea6d53a (patch)
tree9be188b20492989a2a2aa10e7bfe90e2f7540161 /dev-util
parentnet-vpn/openvpn: add 2.6.9 (diff)
downloadgentoo-50e5705ceb615fddd35e4ea300fe3418bea6d53a.tar.gz
gentoo-50e5705ceb615fddd35e4ea300fe3418bea6d53a.tar.bz2
gentoo-50e5705ceb615fddd35e4ea300fe3418bea6d53a.zip
dev-util/google-perftools: add 2.15
Fix large page configure switch Closes: https://bugs.gentoo.org/887273 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/google-perftools/Manifest1
-rw-r--r--dev-util/google-perftools/google-perftools-2.15.ebuild118
-rw-r--r--dev-util/google-perftools/metadata.xml20
3 files changed, 139 insertions, 0 deletions
diff --git a/dev-util/google-perftools/Manifest b/dev-util/google-perftools/Manifest
index 4957d61fd891..d7f8811fa9f0 100644
--- a/dev-util/google-perftools/Manifest
+++ b/dev-util/google-perftools/Manifest
@@ -1,2 +1,3 @@
DIST gperftools-2.10.tar.gz 926512 BLAKE2B e92fb751f9e695d21edf5fce443f3d3641fcff15cbd6b5d868bc77fbe622594be824b75c8d45513c7f82b9e574c690133b8502d4574162948a77886d5166b92d SHA512 4400711723be9401f519d85b3b69c026e4715473cbed48ab0573df17abdf895fb971ee969875fe5127a2e8b9aba90d858285e50c8e012384c2c36d5a76b1f0c4
+DIST gperftools-2.15.tar.gz 888271 BLAKE2B 0fb627e36d6677d01081b1d566ad42eee8b87ab94a07cbbc4536a1671b539354bc0d27f6eab249e94317f0d57a9801551aa3b2cceae784231ac69528b61d4d6e SHA512 04551bdfac50812dd8305e0fe6f6ae5b8603f18a5f9cde56657daa634982bfb5eb5303721ea6a8e02f4177aa012535216f1c99b9eda4ce92f046982df41fbcd1
DIST gperftools-2.9.1.tar.gz 924910 BLAKE2B fcf0491e42ff4212a63ab0af422f27f5a625c53a0b33e69f8dede96b004a0f01af104d9791a4b75d38145ae0059f5e2967ea1d09b0712cc4d930ef7aafd4f3ba SHA512 5e07f28da9afc5f1ba3df7f06ad0e146c171d33e1779bbaab21547ed234aaced02e5278c1eb8f92fc45480abd2474d6a2d4c71644fb9378f41088c56cc1bc8ab
diff --git a/dev-util/google-perftools/google-perftools-2.15.ebuild b/dev-util/google-perftools/google-perftools-2.15.ebuild
new file mode 100644
index 000000000000..93208aa22f2d
--- /dev/null
+++ b/dev-util/google-perftools/google-perftools-2.15.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="gperftools-${PV}"
+inherit flag-o-matic autotools vcs-snapshot multilib-minimal
+
+DESCRIPTION="Fast, multi-threaded malloc() and nifty performance analysis tools"
+HOMEPAGE="https://github.com/gperftools/gperftools"
+SRC_URI="https://github.com/gperftools/gperftools/archive/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/4"
+# contains ASM code, with support for
+# freebsd x86/amd64
+# linux amd64/arm/arm64/ppc/ppc64/riscv/x86
+# OSX ppc/amd64
+# AIX ppc/ppc64
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="pagesize-16k pagesize-32k pagesize-64k pagesize-128k pagesize-256k +debug llvm-libunwind minimal optimisememory test static-libs"
+REQUIRED_USE="?? ( pagesize-16k pagesize-32k pagesize-64k pagesize-128k pagesize-256k )"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ # Please keep this if possible on bumps, check Fedora if needs rebasing
+ # Allows correct functionality on e.g. arm64, bug #818871
+ "${FILESDIR}"/${PN}-2.9.1-disable-generic-dynamic-tls.patch
+)
+
+pkg_setup() {
+ # set up the make options in here so that we can actually make use
+ # of them on both compile and install.
+
+ # Avoid building the unit testing if we're not going to execute
+ # tests; this trick here allows us to ignore the tests without
+ # touching the build system (and thus without rebuilding
+ # autotools). Keep commented as long as it's restricted.
+ use test || \
+ MAKEOPTS+=" noinst_PROGRAMS= "
+}
+
+src_prepare() {
+ default
+
+ eautoreconf
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ use optimisememory && append-cppflags -DTCMALLOC_SMALL_BUT_SLOW
+ use pagesize-16k && append-cppflags -DTCMALLOC_PAGE_SIZE_SHIFT=14
+ use pagesize-32k && append-cppflags -DTCMALLOC_PAGE_SIZE_SHIFT=15
+ use pagesize-64k && append-cppflags -DTCMALLOC_PAGE_SIZE_SHIFT=16
+ use pagesize-128k && append-cppflags -DTCMALLOC_PAGE_SIZE_SHIFT=17
+ use pagesize-256k && append-cppflags -DTCMALLOC_PAGE_SIZE_SHIFT=18
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ $(use_enable debug debugalloc)
+ )
+
+ if [[ ${ABI} == x32 ]]; then
+ myeconfargs+=( --enable-minimal )
+ else
+ myeconfargs+=( $(use_enable minimal) )
+ fi
+
+ if use arm64 || use s390; then
+ # Use the same arches for disabling TLS (thread local storage)
+ # as Fedora, but we might need to expand this list if we get
+ # more odd segfaults in consumers like in bug #818871.
+ myeconfargs+=( --disable-general-dynamic-tls )
+ fi
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ if has sandbox ${FEATURES}; then
+ ewarn "Unable to run tests when sandbox is enabled."
+ ewarn "See https://bugs.gentoo.org/290249"
+ return 0
+ fi
+
+ multilib-minimal_src_test
+}
+
+src_install() {
+ if ! use minimal && has x32 ${MULTILIB_ABIS}; then
+ MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/gperftools/heap-checker.h
+ /usr/include/gperftools/heap-profiler.h
+ /usr/include/gperftools/stacktrace.h
+ /usr/include/gperftools/profiler.h
+ )
+ fi
+
+ multilib-minimal_src_install
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ use static-libs || find "${ED}" -name '*.la' -delete || die
+}
diff --git a/dev-util/google-perftools/metadata.xml b/dev-util/google-perftools/metadata.xml
index edf21deb1a1b..1e3420600a79 100644
--- a/dev-util/google-perftools/metadata.xml
+++ b/dev-util/google-perftools/metadata.xml
@@ -16,6 +16,26 @@
memory usage, but should speed up the allocation/free
operations.
</flag>
+ <flag name="pagesize-16k">
+ Use 16K page size for tcmalloc. Larger size makes tcmalloc faster,
+ at the cost of using more space (due to internal fragmentation)
+ </flag>
+ <flag name="pagesize-32k">
+ Use 32K page size for tcmalloc. Larger size makes tcmalloc faster,
+ at the cost of using more space (due to internal fragmentation)
+ </flag>
+ <flag name="pagesize-64k">
+ Use 64K page size for tcmalloc. Larger size makes tcmalloc faster,
+ at the cost of using more space (due to internal fragmentation)
+ </flag>
+ <flag name="pagesize-128k">
+ Use 128K page size for tcmalloc. Larger size makes tcmalloc faster,
+ at the cost of using more space (due to internal fragmentation)
+ </flag>
+ <flag name="pagesize-256k">
+ Use 256K page size for tcmalloc. Larger size makes tcmalloc faster,
+ at the cost of using more space (due to internal fragmentation)
+ </flag>
<flag name="debug">
Build a set of libraries with debug support (so-called
debugalloc). These are available by default but are not needed