summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-01 14:00:29 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-01 15:25:04 +0300
commitbd3e8d1d498aafe2ed2c66b0828d41eaa08f7608 (patch)
tree94d42f6b0f9f9d6e1759859cffdd2aaeaedab5e7 /dev-util/vint/vint-0.3.21.ebuild
parentwww-apps/airdcpp-webui: add 2.11.2 (diff)
downloadgentoo-bd3e8d1d498aafe2ed2c66b0828d41eaa08f7608.tar.gz
gentoo-bd3e8d1d498aafe2ed2c66b0828d41eaa08f7608.tar.bz2
gentoo-bd3e8d1d498aafe2ed2c66b0828d41eaa08f7608.zip
dev-util/vint: enable py3.9, enable py3.10, fix tests
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/vint/vint-0.3.21.ebuild')
-rw-r--r--dev-util/vint/vint-0.3.21.ebuild18
1 files changed, 6 insertions, 12 deletions
diff --git a/dev-util/vint/vint-0.3.21.ebuild b/dev-util/vint/vint-0.3.21.ebuild
index f07e7a81f734..44cd40dc8e15 100644
--- a/dev-util/vint/vint-0.3.21.ebuild
+++ b/dev-util/vint/vint-0.3.21.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Lint tool for Vim script language"
@@ -22,12 +20,8 @@ RDEPEND="
>=dev-python/pyyaml-3.11[${PYTHON_USEDEP}]
"
-distutils_enable_tests pytest
+PATCHES=(
+ "${FILESDIR}/${P}-fix-py3.8.patch"
+)
-python_test() {
- # Tests fail due to python 3.8 warnings in stderr that appear when
- # compiled byte code is disabled
- # https://github.com/Vimjas/vint/issues/355
- [[ "${EPYTHON}" == python3.8 ]] && return
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
+distutils_enable_tests pytest