summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2024-01-01 23:50:23 +0800
committerSam James <sam@gentoo.org>2024-06-26 10:18:53 +0100
commit393a93bbd044785344264dcc13845b82de3ef520 (patch)
treec4707f7e57849ce9a65bd1d37c058033107843da /dev-util/rocminfo
parentdev-util/rocminfo: patches for builtin amdgpu & python 3.12 (diff)
downloadgentoo-393a93bbd044785344264dcc13845b82de3ef520.tar.gz
gentoo-393a93bbd044785344264dcc13845b82de3ef520.tar.bz2
gentoo-393a93bbd044785344264dcc13845b82de3ef520.zip
dev-util/rocminfo: use python-r1 to install python script
Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/rocminfo')
-rw-r--r--dev-util/rocminfo/rocminfo-5.7.1-r1.ebuild18
-rw-r--r--dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild18
2 files changed, 28 insertions, 8 deletions
diff --git a/dev-util/rocminfo/rocminfo-5.7.1-r1.ebuild b/dev-util/rocminfo/rocminfo-5.7.1-r1.ebuild
index 188bd037f938..4b5df7bd0033 100644
--- a/dev-util/rocminfo/rocminfo-5.7.1-r1.ebuild
+++ b/dev-util/rocminfo/rocminfo-5.7.1-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+PYTHON_COMPAT=( python3_{11..12} )
+inherit cmake python-r1
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
@@ -19,8 +20,10 @@ HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
LICENSE="UoI-NCSA"
SLOT="0/$(ver_cut 1-2)"
-RDEPEND=">=dev-libs/rocr-runtime-${PV}"
+RDEPEND=">=dev-libs/rocr-runtime-${PV}
+ ${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}/${PN}-6.0.0-detect-builtin-amdgpu.patch"
@@ -29,7 +32,8 @@ PATCHES=(
src_prepare() {
sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
- sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
+ sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" \
+ -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
cmake_src_prepare
}
@@ -37,3 +41,9 @@ src_configure() {
local mycmakeargs=( -DROCRTST_BLD_TYPE=Release )
cmake_src_configure
}
+
+src_install() {
+ cmake_src_install
+ rm "${ED}/usr/bin/rocm_agent_enumerator" || die
+ python_foreach_impl python_doexe rocm_agent_enumerator "${BUILD_DIR}"/rocm_agent_enumerator
+}
diff --git a/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild b/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild
index 188bd037f938..4b5df7bd0033 100644
--- a/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild
+++ b/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild
@@ -1,9 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake
+PYTHON_COMPAT=( python3_{11..12} )
+inherit cmake python-r1
if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
@@ -19,8 +20,10 @@ HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
LICENSE="UoI-NCSA"
SLOT="0/$(ver_cut 1-2)"
-RDEPEND=">=dev-libs/rocr-runtime-${PV}"
+RDEPEND=">=dev-libs/rocr-runtime-${PV}
+ ${PYTHON_DEPS}"
DEPEND="${RDEPEND}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}/${PN}-6.0.0-detect-builtin-amdgpu.patch"
@@ -29,7 +32,8 @@ PATCHES=(
src_prepare() {
sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
- sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
+ sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" \
+ -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
cmake_src_prepare
}
@@ -37,3 +41,9 @@ src_configure() {
local mycmakeargs=( -DROCRTST_BLD_TYPE=Release )
cmake_src_configure
}
+
+src_install() {
+ cmake_src_install
+ rm "${ED}/usr/bin/rocm_agent_enumerator" || die
+ python_foreach_impl python_doexe rocm_agent_enumerator "${BUILD_DIR}"/rocm_agent_enumerator
+}