summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/pretrace/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/pretrace/files')
-rw-r--r--dev-util/pretrace/files/pretrace-0.4--as-needed.diff12
-rw-r--r--dev-util/pretrace/files/pretrace-0.4-build.patch15
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/pretrace/files/pretrace-0.4--as-needed.diff b/dev-util/pretrace/files/pretrace-0.4--as-needed.diff
new file mode 100644
index 000000000000..19b66ed40c09
--- /dev/null
+++ b/dev-util/pretrace/files/pretrace-0.4--as-needed.diff
@@ -0,0 +1,12 @@
+diff -uNr libpretrace-0.4/Makefile libpretrace-0.4.new/Makefile
+--- libpretrace-0.4/Makefile 2005-12-15 12:50:06.000000000 +0000
++++ libpretrace-0.4.new/Makefile 2006-04-01 23:53:00.000000000 +0100
+@@ -14,7 +14,7 @@
+ @echo 'type `make install` to install to $(PREFIX)'
+
+ ptgenmap: libpretrace.so ptgenmap.o
+- $(CC) $(CFLAGS) $(LDFLAGS) -g -L. -lpretrace ptgenmap.o -o ptgenmap
++ $(CC) $(CFLAGS) $(LDFLAGS) -g -L. ptgenmap.o -lpretrace -o ptgenmap
+
+ ptgenmap.o:
+ $(CC) $(CFLAGS) -Wall -g -fPIC -c ptgenmap.c
diff --git a/dev-util/pretrace/files/pretrace-0.4-build.patch b/dev-util/pretrace/files/pretrace-0.4-build.patch
new file mode 100644
index 000000000000..4d7056fa83f7
--- /dev/null
+++ b/dev-util/pretrace/files/pretrace-0.4-build.patch
@@ -0,0 +1,15 @@
+fix building with newer glibc
+
+http://bugs.gentoo.org/227923
+
+--- pretrace.h
++++ pretrace.h
+@@ -20,3 +20,8 @@
+ #include <sys/time.h>
+ # define RANDOMIZE(x) { struct timeval tv; gettimeofday(&tv, NULL); x = tv.tv_usec; }
+ #endif
++
++#include <unistd.h>
++#ifndef ARG_MAX
++# define ARG_MAX sysconf(_SC_ARG_MAX)
++#endif