summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/premake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/premake')
-rw-r--r--dev-util/premake/Manifest2
-rw-r--r--dev-util/premake/files/archless.patch36
-rw-r--r--dev-util/premake/metadata.xml18
-rw-r--r--dev-util/premake/premake-3.7.ebuild25
-rw-r--r--dev-util/premake/premake-4.3-r1.ebuild31
5 files changed, 112 insertions, 0 deletions
diff --git a/dev-util/premake/Manifest b/dev-util/premake/Manifest
new file mode 100644
index 000000000000..13ff884f7525
--- /dev/null
+++ b/dev-util/premake/Manifest
@@ -0,0 +1,2 @@
+DIST premake-4.3-src.zip 514366 SHA256 36536490f8928d8ecde135da80cd8b751ea5bebe50cabba5c0de49cd41cb2780 SHA512 df3a4f1e04afb6ae9acf06c063b084a4bcc7c48a98eebeb242eafef40de4097c6a6fe549369d9538b93efea35244222b9d26c15824f126a67b8f80abaecdf001 WHIRLPOOL f39bb097379206818989b5076b2310ea26252f694382eaec1ed5b3785318dbdb0fbd3669094f2756979fbf67c771f080f76dd9418da3d8326f3e93b8e15957e4
+DIST premake-src-3.7.zip 427727 SHA256 b59841a519e75d5b6566848a2c5be2f91455bf0cc6ae4d688fcbd4c40db934d5 SHA512 351b26b9ee738e97b1828e7c26fe1538fb1509fbdc030da3d87fc28b1daa7966bc50ba8043062d35b37fa3929d909533b723241e1f98e438a039c6f9d61a46f4 WHIRLPOOL ddebaac25b0382620dba378ca8f3f3340cbe630cc081858cc94a6dc4d4a5a13c9e09706af5dc602e6886a0e3f720cc68515f38bc112fd82a389593a2b3514bf6
diff --git a/dev-util/premake/files/archless.patch b/dev-util/premake/files/archless.patch
new file mode 100644
index 000000000000..68719bc3669c
--- /dev/null
+++ b/dev-util/premake/files/archless.patch
@@ -0,0 +1,36 @@
+diff -Naur premake-4.3.orig/build/gmake.unix/Premake4.make premake-4.3/build/gmake.unix/Premake4.make
+--- premake-4.3.orig/build/gmake.unix/Premake4.make 2010-11-16 06:29:14.000000000 -0500
++++ premake-4.3/build/gmake.unix/Premake4.make 2011-04-18 07:24:59.374986001 -0400
+@@ -26,13 +26,12 @@
+ DEFINES += -DNDEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) $(ARCH) -Wall -Os
+- CXXFLAGS += $(CFLAGS)
+- LDFLAGS += -s -rdynamic
++ CFLAGS += $(CPPFLAGS) -Wall
++ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+ LDDEPS +=
+- LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(ARCH) $(LIBS)
++ LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(LIBS)
+ define PREBUILDCMDS
+ endef
+ define PRELINKCMDS
+@@ -48,13 +47,12 @@
+ DEFINES += -D_DEBUG -DLUA_USE_POSIX -DLUA_USE_DLOPEN
+ INCLUDES += -I../../src/host/lua-5.1.4/src
+ CPPFLAGS += -MMD -MP $(DEFINES) $(INCLUDES)
+- CFLAGS += $(CPPFLAGS) $(ARCH) -Wall -g
+- CXXFLAGS += $(CFLAGS)
++ CFLAGS += $(CPPFLAGS) -Wall -g
+ LDFLAGS += -rdynamic
+ LIBS += -lm -ldl
+ RESFLAGS += $(DEFINES) $(INCLUDES)
+ LDDEPS +=
+- LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(ARCH) $(LIBS)
++ LINKCMD = $(CC) -o $(TARGET) $(OBJECTS) $(LDFLAGS) $(RESOURCES) $(LIBS)
+ define PREBUILDCMDS
+ endef
+ define PRELINKCMDS
diff --git a/dev-util/premake/metadata.xml b/dev-util/premake/metadata.xml
new file mode 100644
index 000000000000..f5d04b333f6c
--- /dev/null
+++ b/dev-util/premake/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>titanofold@gentoo.org</email>
+ <name>Aaron W. Swenson</name>
+ </maintainer>
+ <longdescription lang="en">
+ Describe your software project just once, using Premake's simple and
+ easy to read syntax, and build it everywhere. Generate project files
+ for Visual Studio, GNU Make, Xcode, Code::Blocks, and more across
+ Windows, Mac OS X, and Linux. Use the full featured Lua scripting
+ engine to make build configuration tasks a breeze.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">premake</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-util/premake/premake-3.7.ebuild b/dev-util/premake/premake-3.7.ebuild
new file mode 100644
index 000000000000..3fa26bbfadb9
--- /dev/null
+++ b/dev-util/premake/premake-3.7.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="http://industriousone.com/premake"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT=$(get_major_version)
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${P/p/P}
+
+src_install() {
+ dobin bin/${PN}
+}
diff --git a/dev-util/premake/premake-4.3-r1.ebuild b/dev-util/premake/premake-4.3-r1.ebuild
new file mode 100644
index 000000000000..9d37258756ca
--- /dev/null
+++ b/dev-util/premake/premake-4.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator eutils
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="http://industriousone.com/premake"
+SRC_URI="mirror://sourceforge/premake/${P}-src.zip"
+
+LICENSE="BSD"
+SLOT=$(get_major_version)
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/archless.patch"
+}
+
+src_compile() {
+ emake -C build/gmake.unix/
+}
+
+src_install() {
+ dobin bin/release/premake4
+}