summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-18 21:35:42 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-18 21:41:14 -0400
commite38deba76eb1f0c07b03ba8d99dd92f985425b5c (patch)
tree123d8338df87b6694134da8efd03e3b7a5d6ff14 /dev-util/mingw64-toolchain
parenttoolchain.eclass: add links/info about USE=rust for gcc-13 (diff)
downloadgentoo-e38deba76eb1f0c07b03ba8d99dd92f985425b5c.tar.gz
gentoo-e38deba76eb1f0c07b03ba8d99dd92f985425b5c.tar.bz2
gentoo-e38deba76eb1f0c07b03ba8d99dd92f985425b5c.zip
dev-util/mingw64-toolchain: use -j1 for make install
Matches the change from bug #906155. This may potentially not be affected with what it builds, but all these packages have a tendendency to be fragile in that regard and there's not much to gain from threads on install. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/mingw64-toolchain')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild5
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild3
2 files changed, 5 insertions, 3 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild
index d3215a0ed723..82af5181e021 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-10.0.0_p1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -220,7 +220,8 @@ src_compile() {
edo "${conf[@]}"
emake
- emake DESTDIR="${MWT_D}" install
+ # -j1 to match bug #906155, other packages may be fragile too
+ emake -j1 DESTDIR="${MWT_D}" install
declare -f mwt-${id} >/dev/null && edo mwt-${id}
declare -f mwt-${id}_${2} >/dev/null && edo mwt-${id}_${2}
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
index 360f880e3610..c1d38e605af9 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
@@ -228,7 +228,8 @@ src_compile() {
edo "${conf[@]}"
emake
- emake DESTDIR="${MWT_D}" install
+ # -j1 to match bug #906155, other packages may be fragile too
+ emake -j1 DESTDIR="${MWT_D}" install
declare -f mwt-${id} >/dev/null && edo mwt-${id}
declare -f mwt-${id}_${2} >/dev/null && edo mwt-${id}_${2}